summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-20 05:47:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-20 05:47:06 +0000
commit92abb6392c1003549e52700906ae1d9077963822 (patch)
tree267e47320f9b9d37f751b257f5974a1c5d64c6d8 /dev-db/hyperdex
parentBump (diff)
downloadgentoo-2-92abb6392c1003549e52700906ae1d9077963822.tar.gz
gentoo-2-92abb6392c1003549e52700906ae1d9077963822.tar.bz2
gentoo-2-92abb6392c1003549e52700906ae1d9077963822.zip
Bump, tests restricted as they fail
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/hyperdex')
-rw-r--r--dev-db/hyperdex/ChangeLog7
-rw-r--r--dev-db/hyperdex/hyperdex-1.0_rc5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index e5831d954cb7..fe02bd70f5dc 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hyperdex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.9 2013/05/10 08:12:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.10 2013/11/20 05:47:06 patrick Exp $
+
+*hyperdex-1.0_rc5 (20 Nov 2013)
+
+ 20 Nov 2013; Patrick Lauer <patrick@gentoo.org> +hyperdex-1.0_rc5.ebuild:
+ Bump, tests restricted as they fail
10 May 2013; Patrick Lauer <patrick@gentoo.org> hyperdex-1.0_rc3.ebuild,
hyperdex-1.0_rc4.ebuild:
diff --git a/dev-db/hyperdex/hyperdex-1.0_rc5.ebuild b/dev-db/hyperdex/hyperdex-1.0_rc5.ebuild
new file mode 100644
index 000000000000..653d05113cf8
--- /dev/null
+++ b/dev-db/hyperdex/hyperdex-1.0_rc5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.0_rc5.ebuild,v 1.1 2013/11/20 05:47:06 patrick Exp $
+EAPI=5
+
+# compile failure in tests, waiting for patch from upstream
+RESTRICT="test"
+
+PYTHON_DEPEND="2:2.6"
+inherit eutils python
+
+DESCRIPTION="A searchable distributed Key-Value Store"
+
+MY_P="${P/_/.}"
+S="${WORKDIR}/${MY_P}"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+python"
+# need to add ruby and java useflags too
+
+DEPEND="dev-cpp/glog
+ dev-libs/cityhash
+ dev-libs/libpo6
+ dev-libs/libe
+ dev-libs/busybee
+ dev-libs/popt
+ dev-libs/replicant"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf --disable-static \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
+}