summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-02-10 05:53:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-02-10 05:53:19 +0000
commitf92f010b0da4ef5d8d8fbab0c660300287990fae (patch)
treedb24d066b11aff492dcfbe6212c3e98fb64f128a /dev-db/hyperdex
parentVersion bump. (diff)
downloadgentoo-2-f92f010b0da4ef5d8d8fbab0c660300287990fae.tar.gz
gentoo-2-f92f010b0da4ef5d8d8fbab0c660300287990fae.tar.bz2
gentoo-2-f92f010b0da4ef5d8d8fbab0c660300287990fae.zip
Bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/hyperdex')
-rw-r--r--dev-db/hyperdex/ChangeLog9
-rw-r--r--dev-db/hyperdex/hyperdex-1.0.5.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index 233df64e6aa5..1444d76e6b65 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hyperdex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.13 2013/12/12 02:46:31 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.14 2014/02/10 05:53:19 patrick Exp $
+
+*hyperdex-1.0.5 (10 Feb 2014)
+
+ 10 Feb 2014; Patrick Lauer <patrick@gentoo.org> +hyperdex-1.0.5.ebuild:
+ Bump
12 Dec 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag from metadata.xml
diff --git a/dev-db/hyperdex/hyperdex-1.0.5.ebuild b/dev-db/hyperdex/hyperdex-1.0.5.ebuild
new file mode 100644
index 000000000000..35e161a1fbb7
--- /dev/null
+++ b/dev-db/hyperdex/hyperdex-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.0.5.ebuild,v 1.1 2014/02/10 05:53:18 patrick Exp $
+EAPI=5
+
+# compile failure in tests, waiting for patch from upstream
+RESTRICT="test"
+
+PYTHON_DEPEND="2:2.6"
+inherit eutils python
+
+DESCRIPTION="A searchable distributed Key-Value Store"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+python"
+# need to add ruby and java useflags too
+
+DEPEND="dev-cpp/glog
+ dev-cpp/sparsehash
+ dev-libs/cityhash
+ dev-libs/libpo6
+ dev-libs/libe
+ dev-libs/busybee
+ dev-libs/popt
+ dev-libs/replicant"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf --disable-static \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
+}