summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:37:20 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:37:20 +0000
commit43890e7389bb8732bf1b5480f7d378e60d6d56b9 (patch)
tree10a91e7a22a0413def003d98df590057741c69b5 /dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild
parentinitial commit (diff)
downloadgentoo-2-43890e7389bb8732bf1b5480f7d378e60d6d56b9.tar.gz
gentoo-2-43890e7389bb8732bf1b5480f7d378e60d6d56b9.tar.bz2
gentoo-2-43890e7389bb8732bf1b5480f7d378e60d6d56b9.zip
initial commit
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild')
-rw-r--r--dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild b/dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild
new file mode 100644
index 000000000000..5376da1d2641
--- /dev/null
+++ b/dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_xql/lib_mysqludf_xql-1.0.0.ebuild,v 1.1 2011/10/19 12:37:20 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="MySQL UDFs which can be used to create XML output directly from MySQL"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_xql/"
+SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ edos2unix API installdb.sql
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
+}
+
+src_install() {
+ local X
+ emake DESTDIR="${D}" install
+ [ -f ${PN}.html ] && dohtml ${PN}.html
+ [ -d doc/html ] && dohtml -r doc/html/.
+ for X in API AUTHORS ChangeLog NEWS README *installdb.sql; do
+ [ -s "${X}" ] && dodoc "${X}"
+ done
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}