summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2009-10-05 15:33:22 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2009-10-05 15:33:22 +0000
commit1e76a22717327b814f2d7927a490aca742193fbf (patch)
tree9d7aa38e7418b84865c9761e4d6c22e3a4a7c393 /dev-db/libiodbc/libiodbc-3.52.7.ebuild
parentFix not verssioned file checksum (bug #287785) (diff)
downloadgentoo-2-1e76a22717327b814f2d7927a490aca742193fbf.tar.gz
gentoo-2-1e76a22717327b814f2d7927a490aca742193fbf.tar.bz2
gentoo-2-1e76a22717327b814f2d7927a490aca742193fbf.zip
version bump, should fix bug 286525
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/libiodbc/libiodbc-3.52.7.ebuild')
-rw-r--r--dev-db/libiodbc/libiodbc-3.52.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/libiodbc/libiodbc-3.52.7.ebuild b/dev-db/libiodbc/libiodbc-3.52.7.ebuild
new file mode 100644
index 000000000000..d7ea85f3b19d
--- /dev/null
+++ b/dev-db/libiodbc/libiodbc-3.52.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.52.7.ebuild,v 1.1 2009/10/05 15:33:22 hoffie Exp $
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="ODBC Interface for Linux."
+HOMEPAGE="http://www.iodbc.org/"
+SRC_URI="http://www.iodbc.org/downloads/iODBC/${P}.tar.gz"
+LICENSE="|| ( LGPL-2 BSD )"
+SLOT="0"
+IUSE="gtk"
+
+DEPEND=">=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-2* )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i.orig \
+ -e '/^cd "$PREFIX"/,/^esac/d' \
+ iodbc/install_libodbc.sh || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ --with-layout=gentoo \
+ $(use_enable gtk gui) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}