summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2006-11-22 23:22:52 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2006-11-22 23:22:52 +0000
commit0f43ae3b01b687103de585a9376dbb714b9d7fed (patch)
tree60ca3a1d678b652cce455db713c60601de583f03 /dev-db/mysql++
parentadded mysql-community (diff)
downloadgentoo-2-0f43ae3b01b687103de585a9376dbb714b9d7fed.tar.gz
gentoo-2-0f43ae3b01b687103de585a9376dbb714b9d7fed.tar.bz2
gentoo-2-0f43ae3b01b687103de585a9376dbb714b9d7fed.zip
Fix signedness bug on ppc, where "char" is unsigned by default.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'dev-db/mysql++')
-rw-r--r--dev-db/mysql++/ChangeLog8
-rw-r--r--dev-db/mysql++/files/digest-mysql++-2.1.1-r13
-rw-r--r--dev-db/mysql++/files/mysql++-signed-char-fix.diff42
-rw-r--r--dev-db/mysql++/mysql++-2.1.1-r1.ebuild53
4 files changed, 105 insertions, 1 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index a58df79a107e..d103bf5021c1 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql++
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.35 2006/06/18 22:57:44 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.36 2006/11/22 23:22:52 hansmi Exp $
+
+*mysql++-2.1.1-r1 (23 Nov 2006)
+
+ 22 Nov 2006; Michael Hanselmann <hansmi@gentoo.org>
+ +files/mysql++-signed-char-fix.diff, +mysql++-2.1.1-r1.ebuild:
+ Fix signedness bug on ppc, where "char" is unsigned by default.
*mysql++-2.1.1 (18 Jun 2006)
diff --git a/dev-db/mysql++/files/digest-mysql++-2.1.1-r1 b/dev-db/mysql++/files/digest-mysql++-2.1.1-r1
new file mode 100644
index 000000000000..5fc16a885b3d
--- /dev/null
+++ b/dev-db/mysql++/files/digest-mysql++-2.1.1-r1
@@ -0,0 +1,3 @@
+MD5 3a42b3422b37c65f88be9162a969d164 mysql++-2.1.1.tar.gz 1855521
+RMD160 bfeeade2be22e761c494e26f46059df2fbc858ac mysql++-2.1.1.tar.gz 1855521
+SHA256 fcd05ac5b4ef0b7b196636907f0ab14860a4b889bd3b3e4f2acc919e2bb05a53 mysql++-2.1.1.tar.gz 1855521
diff --git a/dev-db/mysql++/files/mysql++-signed-char-fix.diff b/dev-db/mysql++/files/mysql++-signed-char-fix.diff
new file mode 100644
index 000000000000..192e40586522
--- /dev/null
+++ b/dev-db/mysql++/files/mysql++-signed-char-fix.diff
@@ -0,0 +1,42 @@
+diff -ru mysql++-2.1.1.orig/lib/qparms.h mysql++-2.1.1/lib/qparms.h
+--- mysql++-2.1.1.orig/lib/qparms.h 2006-04-05 06:44:49.000000000 +0200
++++ mysql++-2.1.1/lib/qparms.h 2006-11-23 00:11:05.000000000 +0100
+@@ -232,7 +232,7 @@
+ /// \param b the 'before' value
+ /// \param o the 'option' value
+ /// \param n the 'num' value
+- SQLParseElement(std::string b, char o, char n) :
++ SQLParseElement(std::string b, char o, short int n) :
+ before(b),
+ option(o),
+ num(n)
+@@ -241,7 +241,7 @@
+
+ std::string before; ///< string inserted before the parameter
+ char option; ///< the parameter option, or blank if none
+- char num; ///< the parameter position to use
++ short int num; ///< the parameter position to use
+ };
+
+ } // end namespace mysqlpp
+diff -ru mysql++-2.1.1.orig/lib/query.cpp mysql++-2.1.1/lib/query.cpp
+--- mysql++-2.1.1.orig/lib/query.cpp 2006-04-05 06:44:49.000000000 +0200
++++ mysql++-2.1.1/lib/query.cpp 2006-11-23 00:16:04.000000000 +0100
+@@ -220,7 +220,7 @@
+ }
+
+ // Finished parsing parameter; save it.
+- parse_elems_.push_back(SQLParseElement(str, option, char(n)));
++ parse_elems_.push_back(SQLParseElement(str, option, n));
+ str = "";
+ name = "";
+ }
+@@ -304,7 +304,7 @@
+ {
+ sbuffer_.str("");
+
+- char num;
++ short int num;
+ SQLString* ss;
+ SQLQueryParms* c;
+
diff --git a/dev-db/mysql++/mysql++-2.1.1-r1.ebuild b/dev-db/mysql++/mysql++-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..0b04cd4d8bf1
--- /dev/null
+++ b/dev-db/mysql++/mysql++-2.1.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.1.1-r1.ebuild,v 1.1 2006/11/22 23:22:52 hansmi Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="C++ API interface to the MySQL database"
+# This is the download page but includes links to other places
+HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~hppa ~mips ~sparc ~ppc ~amd64"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-3"
+RDEPEND="${DEPEND}
+ >=dev-db/mysql-4.0"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}/mysql++-signed-char-fix.diff"
+}
+
+src_compile() {
+ gnuconfig_update
+ local myconf
+ # we want C++ exceptions turned on
+ myconf="--enable-exceptions"
+ # give threads a try
+ myconf="${myconf} --enable-thread-check"
+ # not including the directives to where MySQL is because it seems to
+ # find it just fine without
+
+ # force the cflags into place otherwise they get totally ignored by
+ # configure
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ econf ${myconf} || die "econf failed"
+
+ emake || die "unable to make"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ # install the docs and HTML pages
+ dodoc README LGPL
+ dodoc doc/*
+ dohtml doc/man-html/*
+ prepalldocs
+}