summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-29 20:45:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-29 20:45:04 +0000
commit1a5bea715eefd5ddc1dff3dd75dfe7dc157647f2 (patch)
tree3f78a2e37dbeecc9cbe51b5c43d980998770e55d /dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-1a5bea715eefd5ddc1dff3dd75dfe7dc157647f2.tar.gz
gentoo-2-1a5bea715eefd5ddc1dff3dd75dfe7dc157647f2.tar.bz2
gentoo-2-1a5bea715eefd5ddc1dff3dd75dfe7dc157647f2.zip
Include a config file for easier usage of mysql-proxy. Upstream moved the binary as well, so update init.d to reflect new /usr/bin/ location.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild')
-rw-r--r--dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild b/dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..365c7d6404bc
--- /dev/null
+++ b/dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-proxy/mysql-proxy-0.8.0-r1.ebuild,v 1.1 2010/05/29 20:45:04 robbat2 Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A Proxy for the MySQL Client/Server protocol"
+HOMEPAGE="http://forge.mysql.com/wiki/MySQL_Proxy"
+SRC_URI="mirror://mysql/Downloads/MySQL-Proxy/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+RDEPEND=">=dev-libs/libevent-1.4
+ >=dev-libs/glib-2.16
+ >=dev-lang/lua-5.1"
+DEPEND="${RDEPEND}
+ >=virtual/mysql-5.0
+ dev-util/pkgconfig"
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --includedir=/usr/include/${PN} \
+ --with-mysql \
+ --with-lua \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd-0.8.0-r1 ${PN} || die
+ dodoc ChangeLog NEWS README
+ if useq examples; then
+ docinto examples
+ dodoc examples/*.lua || die
+ dodoc lib/*.lua || die
+ fi
+ # mysql-proxy will refuse to start unless the config file is at most 0660.
+ insinto /etc/mysql
+ insopts -m0660
+ doins "${FILESDIR}"/${PN}.cnf || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You might want to have a look at"
+ einfo "http://dev.mysql.com/tech-resources/articles/proxy-gettingstarted.html"
+ einfo "on how to get started with MySQL Proxy."
+ einfo
+}