summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-02-28 11:33:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-02-28 11:33:42 +0000
commitbd430fc04fe09dedbe7eaa303286e42e058e7768 (patch)
treed9d10a9052afc0e3d8079d945f61b5570fd61363 /dev-db/mysql/mysql-4.1.8.ebuild
parentadd bzip2 (diff)
downloadgentoo-2-bd430fc04fe09dedbe7eaa303286e42e058e7768.tar.gz
gentoo-2-bd430fc04fe09dedbe7eaa303286e42e058e7768.tar.bz2
gentoo-2-bd430fc04fe09dedbe7eaa303286e42e058e7768.zip
Properly fix bug #83431, we missed something last time...
(Portage version: 2.0.51.16)
Diffstat (limited to 'dev-db/mysql/mysql-4.1.8.ebuild')
-rw-r--r--dev-db/mysql/mysql-4.1.8.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-4.1.8.ebuild b/dev-db/mysql/mysql-4.1.8.ebuild
index bf3dcc3ea2a9..30d79b37211a 100644
--- a/dev-db/mysql/mysql-4.1.8.ebuild
+++ b/dev-db/mysql/mysql-4.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.8.ebuild,v 1.7 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.8.ebuild,v 1.8 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -100,10 +100,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {