summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-04-05 21:05:29 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-04-05 21:05:29 +0000
commite6183515549ddc15e501a360d6f82537c2a0de69 (patch)
tree3b2bacd34b0f8da4e7404e799c514538054d2918 /dev-db/octopus
parentEAPI 5 bump wrt bug 543906. (diff)
downloadgentoo-2-e6183515549ddc15e501a360d6f82537c2a0de69.tar.gz
gentoo-2-e6183515549ddc15e501a360d6f82537c2a0de69.tar.bz2
gentoo-2-e6183515549ddc15e501a360d6f82537c2a0de69.zip
EAPI 5 bump wrt bug 543906.
Signed-off-by: monsieurp@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'dev-db/octopus')
-rw-r--r--dev-db/octopus/ChangeLog9
-rw-r--r--dev-db/octopus/octopus-3.0.1-r4.ebuild87
2 files changed, 94 insertions, 2 deletions
diff --git a/dev-db/octopus/ChangeLog b/dev-db/octopus/ChangeLog
index 6037db119226..1ae903031903 100644
--- a/dev-db/octopus/ChangeLog
+++ b/dev-db/octopus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/octopus
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.20 2014/08/10 20:01:37 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/ChangeLog,v 1.21 2015/04/05 21:05:29 monsieurp Exp $
+
+*octopus-3.0.1-r4 (05 Apr 2015)
+
+ 05 Apr 2015; Patrice Clement <monsieurp@gentoo.org> +octopus-3.0.1-r4.ebuild:
+ EAPI 5 bump wrt bug 543906.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> octopus-3.0.1-r3.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-db/octopus/octopus-3.0.1-r4.ebuild b/dev-db/octopus/octopus-3.0.1-r4.ebuild
new file mode 100644
index 000000000000..d083452edf5e
--- /dev/null
+++ b/dev-db/octopus/octopus-3.0.1-r4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/octopus/octopus-3.0.1-r4.ebuild,v 1.1 2015/04/05 21:05:29 monsieurp Exp $
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+JAVA_PKG_WANT_BOOTCLASSPATH="1.5"
+
+inherit versionator java-pkg-2 java-ant-2
+
+MY_PV=${PV//./-}
+MY_PV=${MY_PV/-/.}
+DESCRIPTION="A Java-based Extraction, Transformation, and Loading (ETL) tool"
+SRC_URI="http://download.forge.objectweb.org/${PN}/${PN}-${MY_PV}.src.tar.gz
+ mirror://gentoo/${PN}-xmls-${PV}.tar.bz2"
+HOMEPAGE="http://octopus.objectweb.org"
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+COMMON_DEP="
+ >=dev-java/xerces-2.7
+ >=dev-java/log4j-1.2.8
+ =dev-java/rhino-1.6*
+ =dev-java/junit-3.8*
+ >=dev-java/ant-core-1.4"
+
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}"
+
+# uses enum as identifier
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+TOPDIR="${PN}-$(get_version_component_range 1-2)"
+S=${WORKDIR}/${TOPDIR}/Octopus-src
+
+java_prepare() {
+ rm -fr ${TOPDIR}/maven || die
+ mv "${WORKDIR}/xmls" "${S}/modules/Octopus" || die
+ cd "${S}"/modules || die
+
+ cp "${FILESDIR}/${P}-gentoo-build.xml" build.xml || die
+ java-ant_rewrite-classpath build.xml
+ java-pkg_filter-compiler jikes
+ java-ant_rewrite-bootclasspath 1.5
+
+ epatch "${FILESDIR}/${PN}-jdk-1.5.patch"
+}
+
+EANT_GENTOO_CLASSPATH="xerces-2,rhino-1.6,ant-core,junit,log4j"
+
+src_compile() {
+ cd "${S}/modules" || die
+
+ use source && antflags="${antflags} sourcezip-all"
+
+ eant jar-all $(use_doc docs-all) ${antflags}
+}
+
+RESTRICT="test"
+
+# Would need maven to work properly as the build.xml just launches maven
+#src_test() {
+# eant test
+#}
+
+src_install() {
+ dodoc ChangeLog.txt ReleaseNotes.txt
+
+ cd "${S}/modules" || die
+ java-pkg_dojar dist/*.jar
+
+ if use source; then
+ dodir /usr/share/doc/${PF}/source
+ cp dist/*-src.zip "${D}usr/share/doc/${PF}/source"
+ fi
+
+ if use doc; then
+ docinto html/api
+ # Has multiple javadoc subdirs here
+ java-pkg_dohtml -r docs/*
+ fi
+}