summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-03-18 05:23:54 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-03-18 05:23:54 +0000
commit7d472e6d48af2c008c8f280757b8aaa62ec5b0a5 (patch)
tree64f566ae190511538aa72ed27c3e7e6587f4507f /dev-db/pgaccess
parentinstalls to running kernel, instead of /usr/src/linux symlink'd kernel (diff)
downloadgentoo-2-7d472e6d48af2c008c8f280757b8aaa62ec5b0a5.tar.gz
gentoo-2-7d472e6d48af2c008c8f280757b8aaa62ec5b0a5.tar.bz2
gentoo-2-7d472e6d48af2c008c8f280757b8aaa62ec5b0a5.zip
Initial import. #17668
Diffstat (limited to 'dev-db/pgaccess')
-rw-r--r--dev-db/pgaccess/ChangeLog12
-rw-r--r--dev-db/pgaccess/files/digest-pgaccess-0.98.81
-rw-r--r--dev-db/pgaccess/files/pgaccess-0.98.8.patch37
-rw-r--r--dev-db/pgaccess/pgaccess-0.98.8.ebuild29
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-db/pgaccess/ChangeLog b/dev-db/pgaccess/ChangeLog
new file mode 100644
index 000000000000..d2b5009aa25a
--- /dev/null
+++ b/dev-db/pgaccess/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-db/pgaccess
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/ChangeLog,v 1.1 2003/03/18 05:23:54 nakano Exp $
+
+*pgaccess-0.98.8 (18 Mar 2003)
+
+ 18 Mar 2003; Masatomo Nakano <nakano@gentoo.org> pgaccess-0.98.8.ebuild,
+ files/pgaccess-0.98.8.patch:
+
+ Initial import. Ebuild submitted by Dirk Heinrichs
+ <ext-dirk.heinrichs@nokia.com>.
+
diff --git a/dev-db/pgaccess/files/digest-pgaccess-0.98.8 b/dev-db/pgaccess/files/digest-pgaccess-0.98.8
new file mode 100644
index 000000000000..fbb9fbd83c0f
--- /dev/null
+++ b/dev-db/pgaccess/files/digest-pgaccess-0.98.8
@@ -0,0 +1 @@
+MD5 5f24281f206369d6bc9623a11ec325ab pgaccess-0.98.8.tar.gz 862387
diff --git a/dev-db/pgaccess/files/pgaccess-0.98.8.patch b/dev-db/pgaccess/files/pgaccess-0.98.8.patch
new file mode 100644
index 000000000000..f3ebcedebd3d
--- /dev/null
+++ b/dev-db/pgaccess/files/pgaccess-0.98.8.patch
@@ -0,0 +1,37 @@
+diff -rc pgaccess-0.98.8/Makefile pgaccess-0.98.8.new/Makefile
+*** pgaccess-0.98.8/Makefile Wed Aug 28 18:11:22 2002
+--- pgaccess-0.98.8.new/Makefile Tue Feb 25 08:52:15 2003
+***************
+*** 7,21 ****
+ #
+ #-------------------------------------------------------------------------
+
+! bindir = /usr/bin/X11
+! libdir = /usr/lib/pgaccess
+! wish = /usr/bin/wish
+
+ pgaccess:
+ chmod a+x pgaccess.tcl
+! mkdir $(libdir)
+ cp -R * $(libdir)
+! ln -s $(libdir)/pgaccess.tcl $(bindir)/pgaccess
+
+ all: pgaccess
+
+--- 7,22 ----
+ #
+ #-------------------------------------------------------------------------
+
+! bindir := $(prefix)/usr/bin/X11
+! libdir := $(prefix)/usr/lib/pgaccess
+! wish := `which wish`
+
+ pgaccess:
+ chmod a+x pgaccess.tcl
+! [ -d $(libdir) ] || mkdir -p $(libdir)
+ cp -R * $(libdir)
+! [ -d $(bindir) ] || mkdir -p $(bindir)
+! cd $(bindir) && ln -s ../../lib/pgaccess/pgaccess.tcl $(bindir)/pgaccess
+
+ all: pgaccess
+
diff --git a/dev-db/pgaccess/pgaccess-0.98.8.ebuild b/dev-db/pgaccess/pgaccess-0.98.8.ebuild
new file mode 100644
index 000000000000..4ee842833ee7
--- /dev/null
+++ b/dev-db/pgaccess/pgaccess-0.98.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgaccess/pgaccess-0.98.8.ebuild,v 1.1 2003/03/18 05:23:54 nakano Exp $
+
+DESCRIPTION="a database frontend for postgresql"
+HOMEPAGE="http://www.pgaccess.org/"
+SRC_URI="http://www.pgaccess.org/download/${P}.tar.gz"
+LICENSE="POSTGRESQL"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Build-time dependencies
+DEPEND=">=dev-lang/tcl-8.3.4
+ >=dev-lang/tk-8.3.4
+ >=dev-db/postgresql-7.3"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}.patch || die
+ emake prefix=${D} || die
+}
+
+src_install() {
+ einstall || die
+}