summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-02-21 17:38:21 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-02-21 17:38:21 +0000
commit5a877113d6efed6ecd3bf2c2177ee8d1b76ce0f9 (patch)
tree840b0fa43e13a1da58fcef60508ef429f98bc0c8 /dev-db/phppgadmin
parentVersion bump. (diff)
downloadgentoo-2-5a877113d6efed6ecd3bf2c2177ee8d1b76ce0f9.tar.gz
gentoo-2-5a877113d6efed6ecd3bf2c2177ee8d1b76ce0f9.tar.bz2
gentoo-2-5a877113d6efed6ecd3bf2c2177ee8d1b76ce0f9.zip
Added live ebuild, bug 301052, assign any live ebuild bugs to me.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/ChangeLog10
-rw-r--r--dev-db/phppgadmin/phppgadmin-9999.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-db/phppgadmin/ChangeLog b/dev-db/phppgadmin/ChangeLog
index ea25dd554870..908ecdbdb695 100644
--- a/dev-db/phppgadmin/ChangeLog
+++ b/dev-db/phppgadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/phppgadmin
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.82 2009/01/03 21:00:15 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.83 2010/02/21 17:38:21 reavertm Exp $
+
+*phppgadmin-9999 (21 Feb 2010)
+
+ 21 Feb 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +phppgadmin-9999.ebuild:
+ Added live ebuild, bug 301052
03 Jan 2009; Markus Meier <maekke@gentoo.org> phppgadmin-4.2.2.ebuild:
amd64 stable, bug #250451
diff --git a/dev-db/phppgadmin/phppgadmin-9999.ebuild b/dev-db/phppgadmin/phppgadmin-9999.ebuild
new file mode 100644
index 000000000000..b6706adcef96
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-9999.ebuild,v 1.1 2010/02/21 17:38:21 reavertm Exp $
+
+EAPI="2"
+
+inherit webapp depend.php git
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+EGIT_REPO_URI="git://github.com/xzilla/phppgadmin.git"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE=""
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre postgres session
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}