summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2004-03-16 11:28:25 +0000
committerTal Peer <coredumb@gentoo.org>2004-03-16 11:28:25 +0000
commit363ef8161f2a67309773f3566fc4f051b39996f0 (patch)
tree2b3d7f803c1f4aeb5d31a5a121b42b7080dd8692 /dev-db/sqlite/sqlite-2.8.13.ebuild
parentAdd 2.6.5-rc1. (Manifest recommit) (diff)
downloadgentoo-2-363ef8161f2a67309773f3566fc4f051b39996f0.tar.gz
gentoo-2-363ef8161f2a67309773f3566fc4f051b39996f0.tar.bz2
gentoo-2-363ef8161f2a67309773f3566fc4f051b39996f0.zip
Version bump
Diffstat (limited to 'dev-db/sqlite/sqlite-2.8.13.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-2.8.13.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/sqlite/sqlite-2.8.13.ebuild b/dev-db/sqlite/sqlite-2.8.13.ebuild
new file mode 100644
index 000000000000..141f2ab45b98
--- /dev/null
+++ b/dev-db/sqlite/sqlite-2.8.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.13.ebuild,v 1.1 2004/03/16 11:28:25 coredumb Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/sqlite
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+HOMEPAGE="http://www.sqlite.org"
+DEPEND="virtual/glibc
+ dev-lang/tcl"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+src_compile() {
+ local myconf
+ myconf="--enable-incore-db --enable-tempdb-in-ram"
+ myconf="${myconf} `use_with nls utf8`"
+ econf ${myconf} || die
+ emake all doc || die
+}
+
+src_install () {
+ dodir /usr/{bin,include,lib}
+
+ einstall || die
+
+ dobin lemon
+ dodoc README VERSION
+ doman sqlite.1
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}
+