summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-10 18:18:53 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-10 18:18:53 +0000
commitd676586ca504ac1f5a444588041c1b9f3fa4d052 (patch)
tree35250871f74931156bd596786dd43f0c407017a7 /dev-db/sqlite/sqlite-2.8.16-r4.ebuild
parentStable on ppc wrt bug 159871 (diff)
downloadgentoo-2-d676586ca504ac1f5a444588041c1b9f3fa4d052.tar.gz
gentoo-2-d676586ca504ac1f5a444588041c1b9f3fa4d052.tar.bz2
gentoo-2-d676586ca504ac1f5a444588041c1b9f3fa4d052.zip
Cleanup/fixup ebuilds, remove old ebuilds and patches, fix bug #156299.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-db/sqlite/sqlite-2.8.16-r4.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r4.ebuild84
1 files changed, 43 insertions, 41 deletions
diff --git a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
index 0df1b9af7f4d..eb13cebec680 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
@@ -1,47 +1,51 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.15 2007/02/28 22:03:11 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.16 2007/03/10 18:18:52 chtekk Exp $
-inherit eutils toolchain-funcs alternatives
+inherit eutils alternatives toolchain-funcs
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-DESCRIPTION="SQLite: An SQL Database Engine in a C Library"
+DESCRIPTION="SQLite: an SQL Database Engine in a C Library."
HOMEPAGE="http://www.sqlite.org/"
SRC_URI="http://www.sqlite.org/${P}.tar.gz"
-
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls doc tcl"
+IUSE="doc nls tcl"
DEPEND="doc? ( dev-lang/tcl )
- tcl? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
src_unpack() {
# test
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
+ if has test ${FEATURES} ; then
+ if ! has userpriv ${FEATURES} ; then
ewarn "The userpriv feature must be enabled to run tests."
- ewarn "The testsuite will be skipped."
- fi
- if ! use tcl; then
- ewarn "The tcl useflag must be enabled to run tests."
- ewarn "The testsuite will be skipped."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl ; then
+ eerror "The tcl USE flag must be enabled to run tests."
+ ewarn "Please note that turning on tcl installs runtime"
+ ewarn "support too."
+ eerror "Testsuite will not be run."
fi
fi
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd "${S}"
- use hppa && epatch ${FILESDIR}/${PN}-2.8.15-alignement-fix.patch
+ use hppa && epatch "${FILESDIR}"/${PN}-2.8.15-alignement-fix.patch
- epatch ${FILESDIR}/${P}-multilib.patch
+ epatch "${FILESDIR}"/${P}-multilib.patch
epunt_cxx
- if use nls; then
+ if use nls ; then
ENCODING=${ENCODING-"UTF8"}
else
ENCODING="ISO8859"
@@ -53,27 +57,28 @@ src_unpack() {
-e "s:@@AR@@:$(tc-getAR):g" \
-e "s:@@RANLIB@@:$(tc-getRANLIB):g" \
-e "s:@@ENCODING@@:${ENCODING}:g" \
- ${S}/Makefile.linux-gcc
+ "${S}"/Makefile.linux-gcc
}
src_compile() {
- local myconf
- myconf="--enable-incore-db --enable-tempdb-in-ram"
- myconf="${myconf} `use_enable nls utf8`"
+ local myconf="--enable-incore-db --enable-tempdb-in-ram"
- if ! use tcl; then
+ if ! use tcl ; then
myconf="${myconf} --without-tcl"
fi
- econf ${myconf} || die
- emake all || die
+ econf ${myconf} \
+ $(use_enable nls utf8) \
+ || die "econf failed"
+
+ emake all || die "emake all failed"
- if use doc; then
- emake doc || die
+ if use doc ; then
+ emake doc || die "emake doc failed"
fi
- if use tcl; then
- cp -P ${FILESDIR}/maketcllib.sh ${S}
+ if use tcl ; then
+ cp -P "${FILESDIR}"/maketcllib.sh "${S}"
chmod +x ./maketcllib.sh
./maketcllib.sh
fi
@@ -82,10 +87,10 @@ src_compile() {
src_test() {
if use tcl ; then
if has userpriv ${FEATURES} ; then
- elog "sqlite 2.x is known to have problems on 64 bit architectures"
- elog "if you observe segmentation faults please use 3.x instead"
+ elog "SQLite 2.x is known to have problems on 64 bit architectures."
+ elog "If you observe segmentation faults please use 3.x instead!"
- cd ${S}
+ cd "${S}"
emake test || die "some test failed"
fi
fi
@@ -94,21 +99,18 @@ src_test() {
src_install () {
dodir /usr/{bin,include,$(get_libdir)}
- make DESTDIR="${D}" install || die
+ make DESTDIR="${D}" install || die "make install failed"
newbin lemon lemon-${SLOT}
dodoc README VERSION
doman sqlite.1
- if use doc; then
- docinto html
- dohtml doc/*.html doc/*.txt doc/*.png
- fi
+ use doc && dohtml doc/*.html doc/*.txt doc/*.png
- if use tcl; then
- mkdir ${D}/usr/$(get_libdir)/tclsqlite${PV}
- cp ${S}/tclsqlite.so ${D}/usr/$(get_libdir)/tclsqlite${PV}/
- cp ${S}/pkgIndex.tcl ${D}/usr/$(get_libdir)/tclsqlite${PV}/
+ if use tcl ; then
+ mkdir "${D}"/usr/$(get_libdir)/tclsqlite${PV}
+ cp "${S}"/tclsqlite.so "${D}"/usr/$(get_libdir)/tclsqlite${PV}/
+ cp "${S}"/pkgIndex.tcl "${D}"/usr/$(get_libdir)/tclsqlite${PV}/
fi
}