summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-04-06 18:36:09 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-04-06 18:36:09 +0000
commit530013e09ee6d59f4b97315c38feb7507544c15c (patch)
tree8cb651628fa41b5201a561f45bf228b9e17408a6 /dev-db/sqlite
parentStable on ppc64 (diff)
downloadgentoo-2-530013e09ee6d59f4b97315c38feb7507544c15c.tar.gz
gentoo-2-530013e09ee6d59f4b97315c38feb7507544c15c.tar.bz2
gentoo-2-530013e09ee6d59f4b97315c38feb7507544c15c.zip
add doc and tcltk flag
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog11
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r1.ebuild20
-rw-r--r--dev-db/sqlite/sqlite-3.2.1-r1.ebuild21
3 files changed, 36 insertions, 16 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 11489d10b75e..baa29362c61f 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.73 2005/04/04 13:34:43 gustavoz Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.74 2005/04/06 18:36:09 arj Exp $
+
+ 05 Apr 2005; Anders Rune Jensen <arj@gentoo.org>
+ sqlite-2.8.16-r1.ebuild, sqlite-3.2.1-r1.ebuild:
+ Add useflag doc to install html documentation. This removes the
+ dependency on tcl by default. Thanks to Clinton James for the
+ suggestion. Add doc flag to 3.2.1-r1 as 3.2.1 now supports generating
+ documentation again.
+
04 Apr 2005; Gustavo Zacarias <gustavoz@gentoo.org>
sqlite-2.8.16-r1.ebuild:
Stable on sparc
diff --git a/dev-db/sqlite/sqlite-2.8.16-r1.ebuild b/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
index 295541ce65fb..0b311881a54c 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r1.ebuild,v 1.2 2005/04/04 13:34:43 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r1.ebuild,v 1.3 2005/04/06 18:36:09 arj Exp $
inherit eutils toolchain-funcs
-IUSE="nls"
+IUSE="nls doc tcltk"
DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
SRC_URI="http://www.sqlite.org/${P}.tar.gz"
HOMEPAGE="http://www.sqlite.org"
DEPEND="virtual/libc
- dev-lang/tcl"
+ doc? (dev-lang/tcl)
+ tcltk? (dev-lang/tcl)"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ~ppc sparc ~alpha ~arm ~mips ~hppa ~ppc64 amd64 ~ppc-macos"
@@ -42,11 +43,17 @@ src_compile() {
myconf="--enable-incore-db --enable-tempdb-in-ram"
myconf="${myconf} `use_enable nls utf8`"
econf ${myconf} || die
- emake all doc || die
+ emake all || die
+ if use doc; then
+ emake doc || die
+ fi
+
+ if use tcltk; then
cp -P ${FILESDIR}/maketcllib.sh ${S}
chmod +x ./maketcllib.sh
./maketcllib.sh
+ fi
}
src_install () {
@@ -57,10 +64,15 @@ src_install () {
dobin lemon
dodoc README VERSION
doman sqlite.1
+
+ if use doc; then
docinto html
dohtml doc/*.html doc/*.txt doc/*.png
+ fi
+ if use tcltk; then
mkdir ${D}/usr/lib/tclsqlite${PV}
cp ${S}/tclsqlite.so ${D}/usr/lib/tclsqlite${PV}/
cp ${S}/pkgIndex.tcl ${D}/usr/lib/tclsqlite${PV}/
+ fi
}
diff --git a/dev-db/sqlite/sqlite-3.2.1-r1.ebuild b/dev-db/sqlite/sqlite-3.2.1-r1.ebuild
index fd0dbcf0da96..c0740c5d4600 100644
--- a/dev-db/sqlite/sqlite-3.2.1-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.2.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r1.ebuild,v 1.1 2005/04/02 20:11:34 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r1.ebuild,v 1.2 2005/04/06 18:36:09 arj Exp $
inherit eutils
-IUSE="nothreadsafe"
+IUSE="nothreadsafe doc"
DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
SRC_URI="http://www.sqlite.org/${P}.tar.gz"
@@ -15,18 +15,13 @@ HOMEPAGE="http://www.sqlite.org"
# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
DEPEND="virtual/libc
!nothreadsafe? ( !ppc-macos? ( sys-libs/glibc ) )
- dev-lang/tcl"
+ doc? (dev-lang/tcl)"
SLOT="3"
LICENSE="as-is"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
src_compile() {
- # sqlite includes a doc directory making it impossible to generate docs,
- # which are very important to people adding support for sqlite3 to their
- # programs.
- rm -rf doc/
-
local myconf
myconf="--enable-incore-db --enable-tempdb-in-ram"
# Yes, this is ridiculous, but I'm not the maintainer for this ebuild,
@@ -37,9 +32,12 @@ src_compile() {
else
myconf="${myconf} --disable-threadsafe"
fi
- myconf="--with-tcl=/usr/$(get_libdir)/"
econf ${myconf} || die
- emake all || die # doc is not working yet in 3.1.2
+ emake all || die
+
+ if use doc; then
+ emake doc
+ fi
}
# In case we ever want testing support; note: this needs more work, as
@@ -56,6 +54,9 @@ src_install () {
dobin lemon
dodoc README VERSION
doman sqlite3.1
+
+ if use doc; then
docinto html
dohtml doc/*.html doc/*.txt doc/*.png
+ fi
}