summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-03-01 02:56:39 +0000
committerThomas Sachau <tommy@gentoo.org>2009-03-01 02:56:39 +0000
commit9874bd52d616dae1c96681c8d1337934a603d354 (patch)
treedf03ba8b779c1ba41e9be6f00aaa2aad6b028441 /dev-db/sqlite
parent(non maintainer commit) Version bump, ebuild by Mounir Lamouri in bug 235720 (diff)
downloadgentoo-2-9874bd52d616dae1c96681c8d1337934a603d354.tar.gz
gentoo-2-9874bd52d616dae1c96681c8d1337934a603d354.tar.bz2
gentoo-2-9874bd52d616dae1c96681c8d1337934a603d354.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.11-reference.patch21
-rw-r--r--dev-db/sqlite/sqlite-3.6.11.ebuild90
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index b0530d0a378e..6dc28dedc715 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.222 2009/02/26 20:03:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.223 2009/03/01 02:56:38 tommy Exp $
+
+*sqlite-3.6.11 (01 Mar 2009)
+
+ 01 Mar 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +files/sqlite-3.6.11-reference.patch, +sqlite-3.6.11.ebuild:
+ Version bump
26 Feb 2009; Brent Baude <ranger@gentoo.org> sqlite-3.6.10.ebuild:
stable ppc64, bug 259462
diff --git a/dev-db/sqlite/files/sqlite-3.6.11-reference.patch b/dev-db/sqlite/files/sqlite-3.6.11-reference.patch
new file mode 100644
index 000000000000..a8e924aa8f3f
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.6.11-reference.patch
@@ -0,0 +1,21 @@
+--- Makefile.in 2009-02-15 14:07:08.000000000 +0100
++++ /root/Makefile.in 2009-02-28 18:02:27.000000000 +0100
+@@ -163,7 +163,7 @@
+
+ # Object files for the SQLite library (non-amalgamation).
+ #
+-OBJS0 = alter.lo analyze.lo attach.lo auth.lo bitvec.lo btmutex.lo \
++OBJS0 = alter.lo analyze.lo attach.lo auth.lo backup.lo bitvec.lo btmutex.lo \
+ btree.lo build.lo callback.lo complete.lo date.lo \
+ delete.lo expr.lo fault.lo func.lo global.lo \
+ hash.lo journal.lo insert.lo legacy.lo loadext.lo \
+@@ -518,6 +518,9 @@
+ auth.lo: $(TOP)/src/auth.c $(HDR)
+ $(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/auth.c
+
++backup.lo: $(TOP)/src/backup.c $(HDR)
++ $(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/backup.c
++
+ bitvec.lo: $(TOP)/src/bitvec.c $(HDR)
+ $(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/bitvec.c
+
diff --git a/dev-db/sqlite/sqlite-3.6.11.ebuild b/dev-db/sqlite/sqlite-3.6.11.ebuild
new file mode 100644
index 000000000000..7af2b3f95d65
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.6.11.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.11.ebuild,v 1.1 2009/03/01 02:56:38 tommy Exp $
+
+EAPI="1"
+
+inherit autotools eutils flag-o-matic libtool versionator
+
+DESCRIPTION="an SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+DOC_BASE="$(get_version_component_range 1-3)"
+DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz
+ doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc soundex tcl +threadsafe"
+RESTRICT="!tcl? ( test )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+pkg_setup() {
+ # test
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the testsuite."
+ eerror "Testsuite will not be run."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/sandbox-fix2.patch
+ epatch "${FILESDIR}"/${P}-reference.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ # not available via configure and requested in bug #143794
+ use soundex && append-flags -DSQLITE_SOUNDEX=1
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable threadsafe) \
+ $(use_enable threadsafe cross-thread-connections) \
+ $(use_enable tcl)
+ emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
+}
+
+src_test() {
+ if has userpriv ${FEATURES}; then
+ local test=test
+ use debug && tets=fulltest
+ emake ${test} || die "some test(s) failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)/${P}" \
+ install \
+ || die "emake install failed"
+
+ doman sqlite3.1 || die
+
+ if use doc; then
+ # Naming scheme changes randomly between - and _ in releases
+ # http://www.sqlite.org/cvstrac/tktview?tn=3523
+ dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die
+ fi
+}
+
+pkg_postinst() {
+ elog "sqlite-3.6.X is not totally backwards compatible, see"
+ elog "http://www.sqlite.org/releaselog/3_6_0.html for full details."
+}