summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-04-04 16:43:39 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-04-04 16:43:39 +0000
commit6dddcdf458d2a9e08812573bec3a583c47129f02 (patch)
tree9e7c72447f9f02d5f52f437a168fdd44d4f767af /dev-db/sqliteman
parentMigrate to EAPI 5. (diff)
downloadgentoo-2-6dddcdf458d2a9e08812573bec3a583c47129f02.tar.gz
gentoo-2-6dddcdf458d2a9e08812573bec3a583c47129f02.tar.bz2
gentoo-2-6dddcdf458d2a9e08812573bec3a583c47129f02.zip
Migrate to EAPI 5.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-db/sqliteman')
-rw-r--r--dev-db/sqliteman/ChangeLog10
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-db/sqliteman/ChangeLog b/dev-db/sqliteman/ChangeLog
index 0e314ffcc557..9d439a22d01d 100644
--- a/dev-db/sqliteman/ChangeLog
+++ b/dev-db/sqliteman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqliteman
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqliteman/ChangeLog,v 1.8 2013/03/02 19:50:42 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqliteman/ChangeLog,v 1.9 2015/04/04 16:43:39 kensington Exp $
+
+*sqliteman-1.2.2-r1 (04 Apr 2015)
+
+ 04 Apr 2015; Michael Palimaka <kensington@gentoo.org>
+ +sqliteman-1.2.2-r1.ebuild:
+ Migrate to EAPI 5.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> sqliteman-1.2.2.ebuild:
Move Qt dependencies to the new category
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..8cc32a8421f5
--- /dev/null
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqliteman/sqliteman-1.2.2-r1.ebuild,v 1.1 2015/04/04 16:43:39 kensington Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
+HOMEPAGE="http://sqliteman.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[sqlite]
+ x11-libs/qscintilla"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ # remove bundled lib
+ rm -rf "${S}"/${PN}/qscintilla2
+
+ cmake-utils_src_prepare
+}