summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-09 18:41:21 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-09 18:41:21 +0000
commit20b3344e14c606e604f126d3b87d97b133cb4779 (patch)
tree8400af797c5ee3b6107ce64f8e23b36105860f59 /dev-db/unixODBC
parentVersion bump; added documentation; lintool'd and repoman'd; added SLOT and KE... (diff)
downloadgentoo-2-20b3344e14c606e604f126d3b87d97b133cb4779.tar.gz
gentoo-2-20b3344e14c606e604f126d3b87d97b133cb4779.tar.bz2
gentoo-2-20b3344e14c606e604f126d3b87d97b133cb4779.zip
New version. Fixes #2179
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog8
-rw-r--r--dev-db/unixODBC/files/digest-unixODBC-2.2.21
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.2.ebuild49
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 7a0c77cb1d9e..1c59791afec3 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-db/unixODBC
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.2 2002/07/09 18:41:21 rphillips Exp $
+*unixODBC-2.2.2 (9 Jul 2002)
+
+ 9 Jul 2002; Ryan Phillips <rphillips@gentoo.org> unixODBC-2.2.2.ebuild :
+
+ New version
+
*unixODBC-2.0.6 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/dev-db/unixODBC/files/digest-unixODBC-2.2.2 b/dev-db/unixODBC/files/digest-unixODBC-2.2.2
new file mode 100644
index 000000000000..617cb5098d27
--- /dev/null
+++ b/dev-db/unixODBC/files/digest-unixODBC-2.2.2
@@ -0,0 +1 @@
+MD5 cbd9305c06b315effb970f843df8ac1c unixODBC-2.2.2.tar.gz 2134570
diff --git a/dev-db/unixODBC/unixODBC-2.2.2.ebuild b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
new file mode 100644
index 000000000000..42f110cb5283
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.1 2002/07/09 18:41:21 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ODBC Interface for Linux"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
+HOMEPAGE="http://www.unixodbc.org"
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-3.0* )"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Original Makefile.in is trying to create and install files directly in /etc so we
+ # need to edit the file to make it DESTDIR sensitive.
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" -e "s:mkdir -p :mkdir -p \${DESTDIR}/:" Makefile.orig > Makefile.in
+}
+
+src_compile() {
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
+}