summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-11-05 13:50:17 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-11-05 13:50:17 +0000
commit1193982c06cdcda3bb4284d1e405c1bccbf86bf2 (patch)
treeefceea85497772c7b3fd11a0a0e575fde8e1fbc3 /dev-db
parentInitial import. Closes #39429. (Manifest recommit) (diff)
downloadgentoo-2-1193982c06cdcda3bb4284d1e405c1bccbf86bf2.tar.gz
gentoo-2-1193982c06cdcda3bb4284d1e405c1bccbf86bf2.tar.bz2
gentoo-2-1193982c06cdcda3bb4284d1e405c1bccbf86bf2.zip
added threads support
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/postgresql-7.3.8.ebuild5
-rw-r--r--dev-db/postgresql/postgresql-7.4.6.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 7181f452d1b7..befb36c9ee0b 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.149 2004/10/24 17:15:22 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.150 2004/11/05 13:50:17 nakano Exp $
+
+ 05 Nov 2004; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.8.ebuild,
+ postgresql-7.4.6.ebuild:
+ Added threads support.
*postgresql-7.3.8 (24 Oct 2004)
diff --git a/dev-db/postgresql/postgresql-7.3.8.ebuild b/dev-db/postgresql/postgresql-7.3.8.ebuild
index 2fd52e3f80f7..302820fa9e6f 100644
--- a/dev-db/postgresql/postgresql-7.3.8.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.8.ebuild,v 1.1 2004/10/24 17:15:22 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.8.ebuild,v 1.2 2004/11/05 13:50:17 nakano Exp $
inherit eutils gnuconfig flag-o-matic java-pkg
@@ -14,7 +14,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~hppa ~ia64 ~mips"
-IUSE="doc java libg++ nls pam perl python readline ssl tcltk zlib"
+IUSE="doc java libg++ nls pam perl python readline ssl tcltk zlib threads"
DEPEND="virtual/libc
sys-devel/autoconf
@@ -87,6 +87,7 @@ src_compile() {
use pam && myconf="$myconf --with-pam"
use readline || myconf="$myconf --without-readline"
use zlib || myconf="$myconf --without-zlib"
+ use threads && myconf="$myconf --enable-thread-safety"
# these are the only working CFLAGS I could get on ppc, so locking them
# down, anything more aggressive fails (i.e. -mcpu or -Ox)
diff --git a/dev-db/postgresql/postgresql-7.4.6.ebuild b/dev-db/postgresql/postgresql-7.4.6.ebuild
index fa24eec3d7f7..8a683007eeaa 100644
--- a/dev-db/postgresql/postgresql-7.4.6.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.6.ebuild,v 1.1 2004/10/24 17:15:22 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.6.ebuild,v 1.2 2004/11/05 13:50:17 nakano Exp $
inherit eutils gnuconfig flag-o-matic java-pkg
@@ -15,7 +15,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
-IUSE="ssl nls java python tcltk perl libg++ pam readline zlib doc pg-hier pg-vacuumdelay pg-intdatetime"
+IUSE="ssl nls java python tcltk perl libg++ pam readline zlib doc pg-hier pg-vacuumdelay pg-intdatetime threads"
DEPEND="virtual/libc
sys-devel/autoconf
@@ -107,6 +107,7 @@ src_compile() {
use readline || myconf="$myconf --without-readline"
use zlib || myconf="$myconf --without-zlib"
use pg-intdatetime && myconf="$myconf --enable-integer-datetimes"
+ use threads && myconf="$myconf --enable-thread-safety"
# these are the only working CFLAGS I could get on ppc, so locking them
# down, anything more aggressive fails (i.e. -mcpu or -Ox)