summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-12-29 14:42:33 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-12-29 14:42:33 +0000
commit120ecf57abb82ec8a44ee39cbd75bdb1e80ec8bb (patch)
treec3b8ff6bab62df98e8311c402fe6df5f12011161 /dev-db
parentstrscan has been included since ruby 1.8 (diff)
downloadgentoo-2-120ecf57abb82ec8a44ee39cbd75bdb1e80ec8bb.tar.gz
gentoo-2-120ecf57abb82ec8a44ee39cbd75bdb1e80ec8bb.tar.bz2
gentoo-2-120ecf57abb82ec8a44ee39cbd75bdb1e80ec8bb.zip
Fixed Java dependency. Close #36723.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/postgresql-7.3.4-r1.ebuild15
-rw-r--r--dev-db/postgresql/postgresql-7.3.5.ebuild21
-rw-r--r--dev-db/postgresql/postgresql-7.4-r1.ebuild15
-rw-r--r--dev-db/postgresql/postgresql-7.4.1.ebuild15
5 files changed, 48 insertions, 24 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index f380196dbfe7..2c953795d6cb 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.75 2003/12/25 04:39:37 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.76 2003/12/29 14:42:33 nakano Exp $
+
+ 29 Dec 2003; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.4-r1.ebuild,
+ postgresql-7.3.5.ebuild, postgresql-7.4-r1.ebuild, postgresql-7.4.1.ebuild:
+ Fixed Java dependency. Close #36723.
*postgresql-7.4.1 (25 Dec 2003)
diff --git a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
index 498c2dc32943..1b308b8dbd83 100644
--- a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.5 2003/12/19 00:59:14 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.6 2003/12/29 14:42:33 nakano Exp $
DESCRIPTION="sophisticated Object-Relational DBMS"
@@ -24,7 +24,8 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( !ppc? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base ) )
- java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+ java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
+ dev-java/java-config ) )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
# java dep workaround for portage bug
@@ -55,7 +56,7 @@ pkg_setup() {
if [ "`use java`" ]; then
if [ "`use amd64`" -o "`use hppa`" ]; then
- ewarn "Ignore USE=\"java\" in amd64/hppa"
+ ewarn "Ignored USE=\"java\" in amd64/hppa"
fi
fi
@@ -89,13 +90,17 @@ src_unpack() {
src_compile() {
filter-flags -ffast-math
- use java && use amd64 || use hppa || check_java_config
+ if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ check_java_config
+ fi
local myconf
use tcltk && myconf="--with-tcl"
use python && use ppc || myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- use java && use amd64 || use hppa || myconf="$myconf --with-java"
+ if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ myconf="$myconf --with-java"
+ fi
use ssl && myconf="$myconf --with-openssl"
use nls && myconf="$myconf --enable-nls"
use libg++ && myconf="$myconf --with-CXX"
diff --git a/dev-db/postgresql/postgresql-7.3.5.ebuild b/dev-db/postgresql/postgresql-7.3.5.ebuild
index ff8952e12d07..63037c706cbf 100644
--- a/dev-db/postgresql/postgresql-7.3.5.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.5.ebuild,v 1.1 2003/12/19 01:42:37 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.5.ebuild,v 1.2 2003/12/29 14:42:33 nakano Exp $
DESCRIPTION="sophisticated Object-Relational DBMS"
@@ -26,7 +26,8 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( !ppc? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base ) )
- java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+ java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
+ dev-java/java-config ) )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
# java dep workaround for portage bug
@@ -55,9 +56,9 @@ pkg_setup() {
fi
fi
- if [ "`use java`" ]; then
- if [ "`use amd64`" -o "`use hppa`" ]; then
- ewarn "Ignore USE=\"java\" in amd64/hppa"
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ if [ "`use amd64`" ]; then
+ ewarn "Ignore USE=\"java\" in amd64"
fi
fi
@@ -91,13 +92,17 @@ src_unpack() {
src_compile() {
filter-flags -ffast-math
- use java && use amd64 || use hppa || check_java_config
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ check_java_config
+ fi
local myconf
use tcltk && myconf="--with-tcl"
use python && use ppc || myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- use java && use amd64 || use hppa || myconf="$myconf --with-java"
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ myconf="$myconf --with-java"
+ fi
use ssl && myconf="$myconf --with-openssl"
use nls && myconf="$myconf --enable-nls"
use libg++ && myconf="$myconf --with-CXX"
@@ -149,7 +154,7 @@ src_install() {
dodoc COPYRIGHT HISTORY INSTALL README register.txt
dodoc contrib/adddepend/*
- if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ if [ "`use java`" -a ! "`use amd64`" ]; then
dojar ${D}/usr/share/postgresql/java/postgresql.jar
rm ${D}/usr/share/postgresql/java/postgresql.jar
fi
diff --git a/dev-db/postgresql/postgresql-7.4-r1.ebuild b/dev-db/postgresql/postgresql-7.4-r1.ebuild
index acef85ba73dc..5b8e81693926 100644
--- a/dev-db/postgresql/postgresql-7.4-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4-r1.ebuild,v 1.2 2003/12/19 00:59:14 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4-r1.ebuild,v 1.3 2003/12/29 14:42:33 nakano Exp $
DESCRIPTION="sophisticated Object-Relational DBMS."
@@ -28,7 +28,8 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
- java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+ java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
+ dev-java/java-config ) )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
# java dep workaround for portage bug
@@ -81,13 +82,17 @@ src_unpack() {
src_compile() {
filter-flags -ffast-math
- use java && check_java_config
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ check_java_config
+ fi
local myconf
use tcltk && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- use java && myconf="$myconf --with-java"
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ myconf="$myconf --with-java"
+ fi
use ssl && myconf="$myconf --with-openssl"
use nls && myconf="$myconf --enable-nls"
use libg++ && myconf="$myconf --with-CXX"
@@ -139,7 +144,7 @@ src_install() {
exeinto /usr/bin
- if [ `use java` ]; then
+ if [ "`use java`" -a ! "`use amd64`" ]; then
dojar ${D}/usr/share/postgresql/java/postgresql.jar || die
rm ${D}/usr/share/postgresql/java/postgresql.jar
fi
diff --git a/dev-db/postgresql/postgresql-7.4.1.ebuild b/dev-db/postgresql/postgresql-7.4.1.ebuild
index 3965ae3d7bb3..83aa078cb83d 100644
--- a/dev-db/postgresql/postgresql-7.4.1.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.1.ebuild,v 1.1 2003/12/25 04:39:37 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.1.ebuild,v 1.2 2003/12/29 14:42:33 nakano Exp $
DESCRIPTION="sophisticated Object-Relational DBMS."
@@ -28,7 +28,8 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
- java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+ java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3
+ dev-java/java-config ) )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
nls? ( sys-devel/gettext )"
# java dep workaround for portage bug
@@ -86,13 +87,17 @@ src_unpack() {
src_compile() {
filter-flags -ffast-math
- use java && check_java_config
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ check_java_config
+ fi
local myconf
use tcltk && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- use java && myconf="$myconf --with-java"
+ if [ "`use java`" -a ! "`use amd64`" ]; then
+ myconf="$myconf --with-java"
+ fi
use ssl && myconf="$myconf --with-openssl"
use nls && myconf="$myconf --enable-nls"
use libg++ && myconf="$myconf --with-CXX"
@@ -145,7 +150,7 @@ src_install() {
exeinto /usr/bin
- if [ `use java` ]; then
+ if [ "`use java`" -a ! "`use amd64`" ]; then
dojar ${D}/usr/share/postgresql/java/postgresql.jar || die
rm ${D}/usr/share/postgresql/java/postgresql.jar
fi