summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-10 21:26:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-10 21:26:57 +0000
commit23d6316c3fe9093d126719fef3813196c009bd76 (patch)
tree25d09e3f19ed45cacff0f95d0a27926ebcad3451 /dev-db
parentamd64 stable, bug #298726 (diff)
downloadgentoo-2-23d6316c3fe9093d126719fef3813196c009bd76.tar.gz
gentoo-2-23d6316c3fe9093d126719fef3813196c009bd76.tar.bz2
gentoo-2-23d6316c3fe9093d126719fef3813196c009bd76.zip
Add "extensions" USE flag (bug #233994).
(Portage version: 15189-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/metadata.xml1
-rw-r--r--dev-db/sqlite/sqlite-3.6.22.ebuild21
3 files changed, 20 insertions, 8 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 7468f2a2ae7b..7a2430ac4e1b 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.315 2010/01/10 13:40:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.316 2010/01/10 21:26:57 arfrever Exp $
+
+ 10 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ sqlite-3.6.22.ebuild, metadata.xml:
+ Add "extensions" USE flag (bug #233994).
10 Jan 2010; Brent Baude <ranger@gentoo.org> sqlite-3.6.21.ebuild:
Marking sqlite-3.6.21 ppc64 for bug 300145
diff --git a/dev-db/sqlite/metadata.xml b/dev-db/sqlite/metadata.xml
index c609876bfb71..0891ecef59c8 100644
--- a/dev-db/sqlite/metadata.xml
+++ b/dev-db/sqlite/metadata.xml
@@ -11,6 +11,7 @@
<description>Take if you want it</description>
</maintainer>
<use>
+ <flag name='extensions'>Enable support for dynamic loading of extensions</flag>
<flag name='fts3'>Full text search using the fts3 module</flag>
<flag name='soundex'>Enable the soundex function to compute soundex
encodings of strings</flag>
diff --git a/dev-db/sqlite/sqlite-3.6.22.ebuild b/dev-db/sqlite/sqlite-3.6.22.ebuild
index 0de4c3737967..791a6698ceb0 100644
--- a/dev-db/sqlite/sqlite-3.6.22.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.22.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.22.ebuild,v 1.3 2010/01/09 22:08:47 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.22.ebuild,v 1.4 2010/01/10 21:26:57 arfrever Exp $
EAPI="2"
-inherit eutils flag-o-matic multilib versionator toolchain-funcs
+inherit eutils flag-o-matic multilib versionator
DESCRIPTION="an SQL Database Engine in a C Library"
HOMEPAGE="http://www.sqlite.org/"
@@ -22,7 +22,7 @@ SRC_URI="
LICENSE="as-is"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc +fts3 icu +readline soundex tcl +threadsafe test"
+IUSE="debug doc extensions +fts3 icu +readline soundex tcl +threadsafe test"
RDEPEND="icu? ( dev-libs/icu )
readline? ( sys-libs/readline )
@@ -74,14 +74,21 @@ src_configure() {
append-cppflags -DNDEBUG
fi
- # amalgamation doesn't have tcl
+ if use tcl || use test; then
+ extensions_option="load-extension"
+ else
+ extensions_option="dynamic-extensions"
+ fi
+
+ # `configure` from amalgamation tarball doesn't support
+ # --with-readline-inc and --(enable|disable)-tcl options.
econf \
+ $(use_enable extensions ${extensions_option}) \
$(use_enable readline) \
- --with-readline-inc=-I"${EPREFIX}"/usr/include/readline \
+ $({ use tcl || use test; } && echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
$(use_enable threadsafe) \
$(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --disable-tcl) \
- $(tc-is-static-only && echo --enable-dynamic-extensions=no)
+ $(use !tcl && use test && echo --disable-tcl)
}
src_compile() {