summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2013-08-17 23:59:02 +0000
committerAlex Legler <a3li@gentoo.org>2013-08-17 23:59:02 +0000
commit45a2b2569734573965a14f8f865cf6a01f97dfb7 (patch)
tree4882b89e838510723e21835e29962710d15db2bb /dev-db
parentDev channel bump. Bump ffmpeg dependency (bug #480936 by floppym). Disable na... (diff)
downloadgentoo-2-45a2b2569734573965a14f8f865cf6a01f97dfb7.tar.gz
gentoo-2-45a2b2569734573965a14f8f865cf6a01f97dfb7.tar.bz2
gentoo-2-45a2b2569734573965a14f8f865cf6a01f97dfb7.zip
Version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8E740238)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.0.5.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 403d3448999a..2e432855dda7 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.489 2013/04/26 09:20:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.490 2013/08/17 23:59:02 a3li Exp $
+
+*phpmyadmin-4.0.5 (17 Aug 2013)
+
+ 17 Aug 2013; Alex Legler <a3li@gentoo.org> +phpmyadmin-4.0.5.ebuild:
+ Version bump
26 Apr 2013; Agostino Sarubbo <ago@gentoo.org> phpmyadmin-3.5.8.ebuild:
Stable for sparc, wrt bug #465420
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.0.5.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.0.5.ebuild
new file mode 100644
index 000000000000..e186f1ed9a1b
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.0.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-4.0.5.ebuild,v 1.1 2013/08/17 23:59:02 a3li Exp $
+
+EAPI="4"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}