summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-04-01 17:10:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-04-01 17:10:02 +0000
commit5feeafdf66e38d542085311afdb74537927e512d (patch)
treec281b36000cb770ec5db2ba8d6ae5b324ca77770 /dev-db
parentDelete older ebuild. (diff)
downloadgentoo-2-5feeafdf66e38d542085311afdb74537927e512d.tar.gz
gentoo-2-5feeafdf66e38d542085311afdb74537927e512d.tar.bz2
gentoo-2-5feeafdf66e38d542085311afdb74537927e512d.zip
Fixing cflags and autotools handling for #361129
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tokyocabinet/ChangeLog11
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.41.ebuild44
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild44
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.45.ebuild45
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild10
5 files changed, 17 insertions, 137 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index 6dae8fea424e..c74c857e14c7 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.33 2011/02/26 08:22:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.34 2011/04/01 17:10:02 patrick Exp $
+
+ 01 Apr 2011; Patrick Lauer <patrick@gentoo.org> -tokyocabinet-1.4.41.ebuild,
+ -tokyocabinet-1.4.42.ebuild, -tokyocabinet-1.4.45.ebuild,
+ tokyocabinet-1.4.47.ebuild:
+ Fixing cflags and autotools handling for #361129
+
+ 01 Apr 2011; Patrick Lauer <patrick@gentoo.org> -tokyocabinet-1.4.41.ebuild,
+ -tokyocabinet-1.4.42.ebuild, -tokyocabinet-1.4.45.ebuild:
+ Remove old
26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
tokyocabinet-1.4.46.ebuild:
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.41.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.41.ebuild
deleted file mode 100644
index b47e623d6c7c..000000000000
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.41.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.41.ebuild,v 1.5 2010/02/01 19:49:43 maekke Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="A library of routines for managing a database"
-HOMEPAGE="http://1978th.net/tokyocabinet/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ppc ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="debug doc examples"
-
-DEPEND="sys-libs/zlib
- app-arch/bzip2"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- if use examples; then
- dodoc example/* || die "Install failed"
- fi
-
- if use doc; then
- dodoc doc/* || die "Install failed"
- fi
-}
-
-src_test() {
- emake -j1 check || die "Tests failed"
-}
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild
deleted file mode 100644
index dcaf0592a4a9..000000000000
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild,v 1.1 2010/01/22 02:49:57 jer Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="A library of routines for managing a database"
-HOMEPAGE="http://1978th.net/tokyocabinet/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="debug doc examples"
-
-DEPEND="sys-libs/zlib
- app-arch/bzip2"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- if use examples; then
- dodoc example/* || die "Install failed"
- fi
-
- if use doc; then
- dodoc doc/* || die "Install failed"
- fi
-}
-
-src_test() {
- emake -j1 check || die "Tests failed"
-}
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.45.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.45.ebuild
deleted file mode 100644
index e42260c81595..000000000000
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.45.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.45.ebuild,v 1.1 2010/06/02 10:55:17 patrick Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="A library of routines for managing a database"
-HOMEPAGE="http://1978th.net/tokyocabinet/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="debug doc examples"
-
-DEPEND="sys-libs/zlib
- app-arch/bzip2"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
- epatch "${FILESDIR}/${PV}.patch"
-}
-
-src_configure() {
- econf $(use_enable debug) --enable-off64
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- if use examples; then
- dodoc example/* || die "Install failed"
- fi
-
- if use doc; then
- dodoc doc/* || die "Install failed"
- fi
-}
-
-src_test() {
- emake -j1 check || die "Tests failed"
-}
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild
index 597d314889c3..b5060a2fab48 100644
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild,v 1.1 2011/02/12 08:58:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.47.ebuild,v 1.2 2011/04/01 17:10:02 patrick Exp $
EAPI="2"
-inherit eutils
+inherit eutils autotools
DESCRIPTION="A library of routines for managing a database"
HOMEPAGE="http://fallabs.com/tokyocabinet/"
@@ -24,10 +24,14 @@ src_prepare() {
sed -i \
-e "/ldconfig/d" \
-e "/DATADIR/d" Makefile.in || die
+ # cflags fix - remove -O2 at end of line
+ sed -i -e 's/-O3"$/"/' configure.in || die
+ eautoreconf || die
}
src_configure() {
- econf $(use_enable debug) --enable-off64
+ # we use the "fastest" target without the -O3
+ econf $(use_enable debug) --enable-off64 --enable-fastest
}
src_install() {