summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-04-25 12:06:13 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-04-25 12:06:13 +0000
commit63566b3d255f7af877e7bcc32c89367fa930c6e6 (patch)
tree07c786d5d13919088500219939fb52e1cb3c7dc2 /dev-db
parentversion bump wrt security #217224 (diff)
downloadgentoo-2-63566b3d255f7af877e7bcc32c89367fa930c6e6.tar.gz
gentoo-2-63566b3d255f7af877e7bcc32c89367fa930c6e6.tar.bz2
gentoo-2-63566b3d255f7af877e7bcc32c89367fa930c6e6.zip
version bump wrt security #219005
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog8
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.11.5.2.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index e6dd792a4ca5..258f85ebd34d 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.302 2008/04/07 20:19:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.303 2008/04/25 12:06:13 hollow Exp $
+
+*phpmyadmin-2.11.5.2 (25 Apr 2008)
+
+ 25 Apr 2008; Benedikt Böhm <hollow@gentoo.org>
+ +phpmyadmin-2.11.5.2.ebuild:
+ version bump wrt security #219005
07 Apr 2008; Raúl Porcel <armin76@gentoo.org> phpmyadmin-2.11.5.1.ebuild:
alpha/sparc stable wrt security #215502
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.11.5.2.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.11.5.2.ebuild
new file mode 100644
index 000000000000..273694a5496f
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.11.5.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.11.5.2.ebuild,v 1.1 2008/04/25 12:06:13 hollow Exp $
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages-utf-8-only"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use crypt ctype pcre session unicode \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "ctype pcre session unicode"
+ eerror
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "mysql or mysqli if using dev-lang/php-5"
+ eerror "mysql if using dev-lang/php-4"
+ eerror
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.11.5-custom-cert.patch
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog
+ rm -f LICENSE CREDITS INSTALL README RELEASE-DATE-${MY_PV} TODO
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.8.0.txt
+ webapp_hook_script "${FILESDIR}"/reconfig-2.8
+ webapp_src_install
+}