summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-06-08 15:53:50 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-06-08 15:53:50 +0000
commit873a109605fd22a8d93295adfe698a303ac6c0e9 (patch)
tree56ffbe126d9e14b670cf5231a3443b7106db0c7c /dev-db
parentadd py3.3 support, test phase and nose for tests providing coverage output (diff)
downloadgentoo-2-873a109605fd22a8d93295adfe698a303ac6c0e9.tar.gz
gentoo-2-873a109605fd22a8d93295adfe698a303ac6c0e9.tar.bz2
gentoo-2-873a109605fd22a8d93295adfe698a303ac6c0e9.zip
Version bump. Fix bug 472598.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/psqlodbc/ChangeLog11
-rw-r--r--dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild42
2 files changed, 50 insertions, 3 deletions
diff --git a/dev-db/psqlodbc/ChangeLog b/dev-db/psqlodbc/ChangeLog
index 038d5072a84d..d405100ecbc6 100644
--- a/dev-db/psqlodbc/ChangeLog
+++ b/dev-db/psqlodbc/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-db/psqlodbc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/psqlodbc/ChangeLog,v 1.1 2012/11/28 20:55:25 titanofold Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/psqlodbc/ChangeLog,v 1.2 2013/06/08 15:53:50 titanofold Exp $
+
+*psqlodbc-09.02.0100 (08 Jun 2013)
+
+ 08 Jun 2013; Aaron W. Swenson <titanofold@gentoo.org>
+ +psqlodbc-09.02.0100.ebuild:
+ Version bump. Fix bug 472598.
*psqlodbc-09.01.0200 (28 Nov 2012)
28 Nov 2012; <titan@gentoo.org> +psqlodbc-09.01.0200.ebuild, +metadata.xml:
New ebuild for psqlodbc. Written by me with help from folks on bug 50368.
-
diff --git a/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild b/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild
new file mode 100644
index 000000000000..e351fb4252b5
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild,v 1.1 2013/06/08 15:53:50 titanofold Exp $
+
+EAPI="4"
+
+inherit multilib versionator
+
+MY_MAJOR=$(get_major_version)
+MY_MINOR=$(get_version_component_range 2)
+PGSLOT="${MY_MAJOR#0}.${MY_MINOR#0}"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc iodbc ssl threads unicode"
+
+DEPEND="dev-db/postgresql-base:${PGSLOT}
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+ ssl? ( dev-libs/openssl )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-libpq="${EROOT%/}/usr/$(get_libdir)/postgresql-${PGSLOT}/bin/pg_config" \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable ssl openssl) \
+ $(use_enable threads pthreads) \
+ $(use_enable unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dohtml docs/*
+}