summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-14 01:06:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-14 01:06:12 +0000
commit9cc42e91cadd8b25589015d413cc5d525d226b4d (patch)
treeab1e4b7d9fa6f8ebf9fd1874e03211886c468ef1 /dev-db
parent3.43.1 version bump for bug 246383. Thanks to midnightflash <midnightflash at... (diff)
downloadgentoo-2-9cc42e91cadd8b25589015d413cc5d525d226b4d.tar.gz
gentoo-2-9cc42e91cadd8b25589015d413cc5d525d226b4d.tar.bz2
gentoo-2-9cc42e91cadd8b25589015d413cc5d525d226b4d.zip
Version bump using the straight patchset from 5.0.60 to aid security. Later revisions will contain new patches. Please note that FEATURES=usersandbox may cause very weird src_test failures.
(Portage version: 2.2_rc13/cvs/Linux 2.6.28-rc2-00338-g65fc716 x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog9
-rw-r--r--dev-db/mysql/mysql-5.0.70.ebuild110
2 files changed, 118 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 42da8f90fc2f..5118003cb841 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.459 2008/08/05 16:30:20 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.460 2008/11/14 01:06:12 robbat2 Exp $
+
+*mysql-5.0.70 (14 Nov 2008)
+
+ 14 Nov 2008; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.0.70.ebuild:
+ Version bump using the straight patchset from 5.0.60 to aid security.
+ Later revisions will contain new patches. Please note that
+ FEATURES=usersandbox may cause very weird src_test failures.
05 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/dev-db/mysql/mysql-5.0.70.ebuild b/dev-db/mysql/mysql-5.0.70.ebuild
new file mode 100644
index 000000000000..5517b3260a96
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.70.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.70.ebuild,v 1.1 2008/11/14 01:06:12 robbat2 Exp $
+
+MY_EXTRAS_VER="20080601"
+SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # archive_gis really sucks a lot, but it's only relevant for the
+ # USE=extraengines case
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Totally broken in 5.0.42"
+ ;;
+
+ 5.0.44|5.0.45|5.0.46|5.0.48|5.0.5[0-6]*)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test \
+ "archive_gis" \
+ "Broken in 5.0.44-56 on big-endian boxes only"
+ ;;
+ esac
+
+ # This was a slight testcase breakage when the read_only security issue
+ # was fixed.
+ case ${PV} in
+ 5.0.54|5.0.51*)
+ mysql_disable_test \
+ "read_only" \
+ "Broken in 5.0.51-54, output in wrong order"
+ ;;
+ esac
+
+ # Ditto to read_only
+ [ "${PV}" == "5.0.51a" ] && \
+ mysql_disable_test \
+ "view" \
+ "Broken in 5.0.51, output in wrong order"
+
+ # x86-specific, OOM issue with some subselects on low memory servers
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
+ # Broke with the YaSSL security issue that didn't affect Gentoo.
+ [ "${PV}" == "5.0.56" ] && \
+ for t in openssl_1 rpl_openssl rpl_ssl ssl \
+ ssl_8k_key ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "OpenSSL tests broken on 5.0.56"
+ done
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
+
+ # We run the test protocols seperately
+ make -j1 test-ns force="--force --vardir=${S}/mysql-test/var-ns"
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ make -j1 test-ps force="--force --vardir=${S}/mysql-test/var-ps"
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ failures=""
+ [[ $retstatus1 -eq 0 ]] || failures="test-ns"
+ [[ $retstatus2 -eq 0 ]] || failures="${failures} test-ps"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}