summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-20 16:14:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-20 16:14:35 +0000
commitccf3ca437033c11170d97595b6106b51df7c5e1e (patch)
tree81eb6ff827779af475305fddc256d096bcf877e3 /dev-db
parentDropped old. (diff)
downloadgentoo-2-ccf3ca437033c11170d97595b6106b51df7c5e1e.tar.gz
gentoo-2-ccf3ca437033c11170d97595b6106b51df7c5e1e.tar.bz2
gentoo-2-ccf3ca437033c11170d97595b6106b51df7c5e1e.zip
Include stdlib.h for function exit in temp.c generation.
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/files/sqlite-2.8.16-exit.patch12
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r5.ebuild8
3 files changed, 22 insertions, 4 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 3549ef24b7bd..cc9917a64c02 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.399 2012/03/20 08:28:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.400 2012/03/20 16:14:35 ssuominen Exp $
+
+ 20 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> sqlite-2.8.16-r5.ebuild,
+ +files/sqlite-2.8.16-exit.patch:
+ Include stdlib.h for function exit() in temp.c generation.
20 Mar 2012; Agostino Sarubbo <ago@gentoo.org> sqlite-3.7.10.ebuild:
Stable for amd64, wrt bug #408385
diff --git a/dev-db/sqlite/files/sqlite-2.8.16-exit.patch b/dev-db/sqlite/files/sqlite-2.8.16-exit.patch
new file mode 100644
index 000000000000..aaccb575e0a9
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-2.8.16-exit.patch
@@ -0,0 +1,12 @@
+temp.c:4:1: warning: incompatible implicit declaration of built-in function ‘exit’
+
+--- Makefile.in
++++ Makefile.in
+@@ -269,6 +269,7 @@
+ #
+ config.h:
+ echo '#include <stdio.h>' >temp.c
++ echo '#include <stdlib.h>' >>temp.c
+ echo 'int main(){printf(' >>temp.c
+ echo '"#define SQLITE_PTR_SZ %d",sizeof(char*));' >>temp.c
+ echo 'exit(0);}' >>temp.c
diff --git a/dev-db/sqlite/sqlite-2.8.16-r5.ebuild b/dev-db/sqlite/sqlite-2.8.16-r5.ebuild
index 3c23a33daf58..7aeb1d408261 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r5.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r5.ebuild,v 1.1 2011/09/09 18:15:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r5.ebuild,v 1.2 2012/03/20 16:14:35 ssuominen Exp $
inherit eutils alternatives toolchain-funcs
@@ -42,7 +42,9 @@ src_unpack() {
use hppa && epatch "${FILESDIR}"/${PN}-2.8.15-alignement-fix.patch
- epatch "${FILESDIR}"/${P}-multilib.patch
+ epatch \
+ "${FILESDIR}"/${P}-multilib.patch \
+ "${FILESDIR}"/${P}-exit.patch
epunt_cxx