summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-11-12 15:36:39 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2011-11-12 15:36:39 +0000
commitcfcef51ca84c9738d1d88a58f7977dc52c83c967 (patch)
tree7aa0044e395d96ef3c6aece52c59ec007bc8e645 /dev-db
parentold (diff)
downloadgentoo-2-cfcef51ca84c9738d1d88a58f7977dc52c83c967.tar.gz
gentoo-2-cfcef51ca84c9738d1d88a58f7977dc52c83c967.tar.bz2
gentoo-2-cfcef51ca84c9738d1d88a58f7977dc52c83c967.zip
Version bump fixes bug 389679. Improved SSL detection patch.
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/ChangeLog8
-rw-r--r--dev-db/pgadmin3/files/ssl-detect-r1.patch64
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.0.ebuild59
3 files changed, 130 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 78f18946fec8..96fc804607a5 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.65 2011/07/11 17:30:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.66 2011/11/12 15:36:39 titanofold Exp $
+
+*pgadmin3-1.14.0 (12 Nov 2011)
+
+ 12 Nov 2011; Aaron W. Swenson <titanofold@gentoo.org>
+ +files/ssl-detect-r1.patch, +pgadmin3-1.14.0.ebuild:
+ Version bump fixes bug 389679. Improved SSL detection patch.
11 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
pgadmin3-1.14.0_beta1.ebuild:
diff --git a/dev-db/pgadmin3/files/ssl-detect-r1.patch b/dev-db/pgadmin3/files/ssl-detect-r1.patch
new file mode 100644
index 000000000000..a54b2ba218a9
--- /dev/null
+++ b/dev-db/pgadmin3/files/ssl-detect-r1.patch
@@ -0,0 +1,64 @@
+--- pgadmin3-1.14.0-rc1.orig/acinclude.m4 2011-06-28 13:44:29.000000000 +0000
++++ pgadmin3-1.14.0-rc1/acinclude.m4 2011-09-05 21:10:03.222953210 +0000
+@@ -406,6 +406,13 @@
+ PGSQL_OLD_LDFLAGS="$LDFLAGS"
+ PGSQL_OLD_CPPFLAGS="$CPPFLAGS"
+
++ PG_INCLUDE=`${PG_CONFIG} --includedir`
++ PG_SVRINCLUDE=`${PG_CONFIG} --includedir-server`
++ PG_PKGINCLUDE=`${PG_CONFIG} --pkgincludedir`
++ CPPFLAGS="$CPPFLAGS -I${PG_INCLUDE} -I${PG_SVRINCLUDE} -I${PG_PKGINCLUDE}"
++
++ PG_VERSION=`${PG_CONFIG} --version`
++
+ AC_LANG_SAVE
+ AC_LANG_C
+ AC_CHECK_LIB(ssl, SSL_library_init, [LIB_SSL=yes], [LIB_SSL=no])
+@@ -477,33 +484,7 @@
+ if test "$LIB_SSL" = "yes"
+ then
+ # Check for SSL support
+- if test "$BUILD_STATIC" = "yes"
+- then
+- AC_MSG_CHECKING(for SSL_connect in libpq.a)
+- if test "$(nm ${PG_LIB}/libpq.a | grep -c SSL_connect)" -gt 0
+- then
+- AC_MSG_RESULT(present)
+- PG_SSL="yes"
+- else
+- AC_MSG_RESULT(not present)
+- PG_SSL="no"
+- fi
+- else
+- if test "$build_cpu-$build_vendor" = "powerpc-apple" -o "$build_cpu-$build_vendor" = "i386-apple" -o "$build_cpu-$build_vendor" = "i686-apple"
+- then
+- AC_MSG_CHECKING(for SSL_connect in -lpq)
+- if test "$(otool -L ${PG_LIB}/libpq.?.dylib | grep -c libssl)" -gt 0
+- then
+- AC_MSG_RESULT(present)
+- PG_SSL="yes"
+- else
+- AC_MSG_RESULT(not present)
+- PG_SSL="no"
+- fi
+- else
+- AC_CHECK_LIB(pq, SSL_connect, [PG_SSL=yes], [PG_SSL=no])
+- fi
+- fi
++ AC_CHECK_DECL([USE_SSL], [PG_SSL=yes], [PG_SSL=no], [[#include <pg_config.h>]])
+ else
+ PG_SSL="no"
+ fi
+@@ -547,12 +528,6 @@
+
+ AC_LANG_RESTORE
+
+- PG_INCLUDE=`${PG_CONFIG} --includedir`
+- PG_SVRINCLUDE=`${PG_CONFIG} --includedir-server`
+- PG_PKGINCLUDE=`${PG_CONFIG} --pkgincludedir`
+- CPPFLAGS="$CPPFLAGS -I${PG_INCLUDE} -I${PG_SVRINCLUDE} -I${PG_PKGINCLUDE}"
+-
+- PG_VERSION=`${PG_CONFIG} --version`
+
+ if test "$build_os" = "mingw32"
+ then
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild
new file mode 100644
index 000000000000..18016bf78d0c
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild,v 1.1 2011/11/12 15:36:39 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit autotools multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="Artistic"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/ssl-detect-r1.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}