summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-12-19 16:21:40 +0000
committerMichał Górny <mgorny@gentoo.org>2010-12-19 16:21:40 +0000
commit5dcece3ce5c7f24160f8ea5c29840fe9501c5185 (patch)
tree6be9d0ad3c1f514d9f7ff94593a7a9303a1a6674 /dev-dotnet/pe-format
parentversion bump (bug #294256) (diff)
downloadgentoo-2-5dcece3ce5c7f24160f8ea5c29840fe9501c5185.tar.gz
gentoo-2-5dcece3ce5c7f24160f8ea5c29840fe9501c5185.tar.bz2
gentoo-2-5dcece3ce5c7f24160f8ea5c29840fe9501c5185.zip
Version bump. The new version features a general code cleanup and fixed alternate installation path support (supposedly Prefix support?).
(Portage version: 2.2.0_alpha9_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/pe-format')
-rw-r--r--dev-dotnet/pe-format/ChangeLog9
-rw-r--r--dev-dotnet/pe-format/pe-format-2.0.3.ebuild26
-rw-r--r--dev-dotnet/pe-format/pe-format-2.0.5.ebuild23
3 files changed, 31 insertions, 27 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index e3568d26252b..42a993161d81 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/pe-format
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.23 2010/11/27 23:49:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.24 2010/12/19 16:21:40 mgorny Exp $
+
+*pe-format-2.0.5 (19 Dec 2010)
+
+ 19 Dec 2010; Michał Górny <mgorny@gentoo.org> -pe-format-2.0.3.ebuild,
+ +pe-format-2.0.5.ebuild:
+ Version bump. The new version features a general code cleanup and fixed
+ alternate installation path support (supposedly Prefix support?).
*pe-format-2.0.4 (27 Nov 2010)
diff --git a/dev-dotnet/pe-format/pe-format-2.0.3.ebuild b/dev-dotnet/pe-format/pe-format-2.0.3.ebuild
deleted file mode 100644
index c4b036d5584e..000000000000
--- a/dev-dotnet/pe-format/pe-format-2.0.3.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.0.3.ebuild,v 1.3 2010/10/13 20:21:51 maekke Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
-HOMEPAGE="http://github.com/mgorny/pe-format2/"
-SRC_URI="http://github.com/downloads/mgorny/${PN}2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="!sys-apps/pe-format2"
-
-src_compile() {
- tc-export CC
- emake || die
-}
-
-src_install() {
- emake ginstall || die
-}
diff --git a/dev-dotnet/pe-format/pe-format-2.0.5.ebuild b/dev-dotnet/pe-format/pe-format-2.0.5.ebuild
new file mode 100644
index 000000000000..345c6902eead
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.0.5.ebuild,v 1.1 2010/12/19 16:21:40 mgorny Exp $
+
+EAPI=2
+inherit autotools-utils
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://github.com/mgorny/pe-format2/"
+SRC_URI="https://github.com/downloads/mgorny/${PN}2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ autotools-utils_src_install
+
+ cd "${AUTOTOOLS_BUILD_DIR}" || die
+ newinitd ${PN}.init ${PN} || die
+ newconfd ${PN}.conf ${PN} || die
+}