summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-09-10 19:35:54 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-09-10 19:35:54 +0000
commited4e808311ae0d3518910420cffcabeb6d058f69 (patch)
tree0dca0ff43055b08d11b982d4b59e4c532bcc2a82 /dev-dotnet/xsp
parentstable on x86, wrt bug #190133 (diff)
downloadgentoo-2-ed4e808311ae0d3518910420cffcabeb6d058f69.tar.gz
gentoo-2-ed4e808311ae0d3518910420cffcabeb6d058f69.tar.bz2
gentoo-2-ed4e808311ae0d3518910420cffcabeb6d058f69.zip
dev-dotnet/xsp: version bump
(Portage version: 2.1.2.12)
Diffstat (limited to 'dev-dotnet/xsp')
-rw-r--r--dev-dotnet/xsp/ChangeLog9
-rw-r--r--dev-dotnet/xsp/files/digest-xsp-1.2.53
-rw-r--r--dev-dotnet/xsp/xsp-1.2.5.ebuild66
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index 6317cd99373d..7fafb9475ec0 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.46 2007/08/27 20:55:11 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.47 2007/09/10 19:35:53 jurek Exp $
+
+*xsp-1.2.5 (10 Sep 2007)
+
+ 10 Sep 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/1.2.5/mod-mono-server.confd, +files/1.2.5/mod-mono-server.initd,
+ +files/1.2.5/xsp.confd, +files/1.2.5/xsp.initd, +xsp-1.2.5.ebuild:
+ Version bump
*xsp-1.2.4-r1 (27 Aug 2007)
diff --git a/dev-dotnet/xsp/files/digest-xsp-1.2.5 b/dev-dotnet/xsp/files/digest-xsp-1.2.5
new file mode 100644
index 000000000000..13b13ee24b07
--- /dev/null
+++ b/dev-dotnet/xsp/files/digest-xsp-1.2.5
@@ -0,0 +1,3 @@
+MD5 adb7871e5ebeefcf8ed959523442c0fb xsp-1.2.5.tar.bz2 189396
+RMD160 4ee53b38f38f2a0e70c8e23d788431eb7d2d5366 xsp-1.2.5.tar.bz2 189396
+SHA256 25c246b7ed3e82a5f3562c2c15db551332830de4c238a53e3260ab7d40cd015a xsp-1.2.5.tar.bz2 189396
diff --git a/dev-dotnet/xsp/xsp-1.2.5.ebuild b/dev-dotnet/xsp/xsp-1.2.5.ebuild
new file mode 100644
index 000000000000..90b315f5d470
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.2.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.2.5.ebuild,v 1.1 2007/09/10 19:35:53 jurek Exp $
+
+inherit mono multilib autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/mono-${PV}"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ "${S}"/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake -j1 || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" \
+ ${D}/usr/bin/xsp{,2} \
+ ${D}/usr/bin/mod-mono-server{,2} \
+ ${D}/usr/bin/asp-state{,2} \
+ ${D}/usr/bin/dbsessmgr{,2} \
+ || die
+
+ newinitd "${FILESDIR}"/${PV}/xsp.initd xsp
+ newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server
+ newconfd "${FILESDIR}"/${PV}/xsp.confd xsp
+ newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}