summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 11:11:20 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 11:11:20 +0000
commit2a77ebd24bd098161751c1a682885fe895ac66b0 (patch)
tree3d624bd12bc72c88f9563ad7e44410a60df0f31c /dev-dotnet
parentUse proper gnome-base/gvfs dependency as a replacement for sys-fs/udisks (diff)
downloadgentoo-2-2a77ebd24bd098161751c1a682885fe895ac66b0.tar.gz
gentoo-2-2a77ebd24bd098161751c1a682885fe895ac66b0.tar.bz2
gentoo-2-2a77ebd24bd098161751c1a682885fe895ac66b0.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/taglib-sharp/ChangeLog8
-rw-r--r--dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild32
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-dotnet/taglib-sharp/ChangeLog b/dev-dotnet/taglib-sharp/ChangeLog
index c226108eb203..29f9de87e0e5 100644
--- a/dev-dotnet/taglib-sharp/ChangeLog
+++ b/dev-dotnet/taglib-sharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/taglib-sharp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/ChangeLog,v 1.37 2012/05/04 03:56:55 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/ChangeLog,v 1.38 2012/07/21 11:11:20 pacho Exp $
+
+*taglib-sharp-2.1.0.0 (21 Jul 2012)
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org> +taglib-sharp-2.1.0.0.ebuild:
+ Version bump.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> taglib-sharp-2.0.4.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -179,4 +184,3 @@
Initial version (fixing bug #170713). Credit goes to Maxxer
<maxxer@yetopen.it> for providing the ebuild with some modifications by yours
truly.
-
diff --git a/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild b/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild
new file mode 100644
index 000000000000..103f49e59f70
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild,v 1.1 2012/07/21 11:11:20 pacho Exp $
+
+EAPI=4
+
+inherit mono
+
+DESCRIPTION="Taglib# 2.0 - Managed tag reader/writer"
+HOMEPAGE="http://download.banshee.fm/taglib-sharp/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed -i -e "s:docs::" \
+ -e "s:examples::" \
+ Makefile.in || die "sedding sense into makefiles failed"
+}
+
+src_configure() {
+ econf --disable-docs
+}