summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-09-04 18:01:23 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-09-04 18:01:23 +0000
commitb22ac7355757f7ab08f492d826f5f0eacafd1075 (patch)
treee230d49e31e212d0ab12c6c8ed32107dc1775b5f /dev-games/cel
parentVersion bump, bug #236722 (diff)
downloadgentoo-2-b22ac7355757f7ab08f492d826f5f0eacafd1075.tar.gz
gentoo-2-b22ac7355757f7ab08f492d826f5f0eacafd1075.tar.bz2
gentoo-2-b22ac7355757f7ab08f492d826f5f0eacafd1075.zip
Version bump, bug #233281
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'dev-games/cel')
-rw-r--r--dev-games/cel/ChangeLog9
-rw-r--r--dev-games/cel/cel-1.2.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-games/cel/ChangeLog b/dev-games/cel/ChangeLog
index 93cc706d6fa5..a3525806a458 100644
--- a/dev-games/cel/ChangeLog
+++ b/dev-games/cel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/cel
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/ChangeLog,v 1.24 2007/11/21 03:27:09 dirtyepic Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/ChangeLog,v 1.25 2008/09/04 18:01:23 nyhm Exp $
+
+*cel-1.2.1 (04 Sep 2008)
+
+ 04 Sep 2008; Tristan Heaven <nyhm@gentoo.org> +cel-1.2.1.ebuild:
+ Version bump, bug #233281
21 Nov 2007; Ryan Hill <dirtyepic@gentoo.org> cel-1.0.1.ebuild,
cel-1.2.ebuild:
diff --git a/dev-games/cel/cel-1.2.1.ebuild b/dev-games/cel/cel-1.2.1.ebuild
new file mode 100644
index 000000000000..a2d703dee47e
--- /dev/null
+++ b/dev-games/cel/cel-1.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-1.2.1.ebuild,v 1.1 2008/09/04 18:01:23 nyhm Exp $
+
+inherit eutils
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A game entity layer based on Crystal Space"
+HOMEPAGE="http://cel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+RDEPEND=">=dev-games/crystalspace-1.1
+ dev-games/hawknl"
+DEPEND="${RDEPEND}
+ dev-util/ftjam"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ --disable-separate-debug-info \
+ --disable-cstest \
+ $(use_with python) \
+ || die
+ jam -q || die "jam failed"
+}
+
+src_install() {
+ jam -q -s DESTDIR="${D}" install || die "jam install failed"
+
+ # Fill cache directory for the examples
+ cp "${D}"/usr/share/${PN}/data/{basic_,}world
+ cslight -video=null "${D}"/usr/share/${PN}/data
+ cp "${D}"/usr/share/${PN}/data/{walktut_,}world
+ cslight -video=null "${D}"/usr/share/${PN}/data
+ rm "${D}"/usr/share/${PN}/data/world
+
+ dodoc docs/history*.txt docs/todo.txt
+}