summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-08 07:22:32 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-08 07:22:32 +0000
commit4f8c898a95c5f10636e6824b5f26de6acd542129 (patch)
tree371923e2cb9671845258c47b3d00d1b67b3bc853 /dev-games
parentNote ldap-bugs mail alias. (diff)
downloadgentoo-2-4f8c898a95c5f10636e6824b5f26de6acd542129.tar.gz
gentoo-2-4f8c898a95c5f10636e6824b5f26de6acd542129.tar.bz2
gentoo-2-4f8c898a95c5f10636e6824b5f26de6acd542129.zip
Use java-pkg-opt-2 eclass
(Portage version: 2.1.2-r8)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog5
-rw-r--r--dev-games/crystalspace/crystalspace-0.99_pre20050823.ebuild75
-rw-r--r--dev-games/crystalspace/crystalspace-1.0.ebuild41
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-0.99_pre200508233
4 files changed, 27 insertions, 97 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 3f94f3f99711..35e3221e5dd6 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/crystalspace
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.22 2007/02/02 06:50:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.23 2007/02/08 07:22:32 nyhm Exp $
+
+ 08 Feb 2007; Tristan Heaven <nyhm@gentoo.org> crystalspace-1.0.ebuild:
+ Use java-pkg-opt-2 eclass
02 Feb 2007; <tupone@gentoo.org> crystalspace-1.0.ebuild:
Work around problems raised with bug #155788 comment 18 by Frank Richter
diff --git a/dev-games/crystalspace/crystalspace-0.99_pre20050823.ebuild b/dev-games/crystalspace/crystalspace-0.99_pre20050823.ebuild
deleted file mode 100644
index c3a031144e22..000000000000
--- a/dev-games/crystalspace/crystalspace-0.99_pre20050823.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.99_pre20050823.ebuild,v 1.3 2006/05/13 03:31:14 vapier Exp $
-
-DESCRIPTION="Portable 3D Game Development Kit written in C++"
-HOMEPAGE="http://crystal.sourceforge.net/"
-SRC_URI="mirror://sourceforge/crystal/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="3ds debug mikmod mng vorbis openal truetype"
-
-RDEPEND="sys-libs/zlib
- >=media-libs/libpng-1.2.1
- >=media-libs/jpeg-6b
- mng? ( media-libs/libmng )
- mikmod? ( media-libs/libmikmod )
- 3ds? ( media-libs/lib3ds )
- truetype? ( >=media-libs/freetype-2.0 )
- openal? ( media-libs/openal )
- vorbis? (
- >=media-libs/libogg-1.0
- >=media-libs/libvorbis-1.0 )
- dev-games/ode
- >=dev-lang/perl-5.6.1
- =media-libs/cal3d-0.11.0_pre*"
-
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.51
- dev-util/jam
- x86? ( dev-lang/nasm )"
-
-S="${WORKDIR}/${PN}"
-
-CRYSTAL_PREFIX="/opt/crystal"
-
-src_compile() {
- # Disabling python entirely, some parts don't build
- #use python || \
- my_conf="${my_conf} --without-python"
-
- use debug && my_conf="${my_conf} --enable-debug"
-
- # Clear out the maya2spr stuff.. it fails to build properly (left as example)
- #sed 's/SubInclude TOP apps import maya2spr ;//' -i apps/import/Jamfile
-
- ./configure --prefix=${CRYSTAL_PREFIX} ${my_conf}
-
- jam all || die "compile failed"
- jam cs-config || die "compile failed"
-}
-
-src_install() {
- jam -sprefix="${D}"${CRYSTAL_PREFIX} install
-
- # Fix cs-config file to point to ${CRYSTAL_PREFIX}
- sed -i 's/^CRYSTAL=.*/CRYSTAL=\/opt\/crystal/' "${D}/${CRYSTAL_PREFIX}/bin/cs-config"
-
- # Symlink cs-config into /usr/bin
- dodir /usr/bin
- dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
-
- # Make sure these files dont have $D
- dosed ${CRYSTAL_PREFIX}/{bin/cs-config,etc/crystalspace/vfs.cfg}
-
- # Fix perms so everyone can read these
- find "${D}"/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
- find "${D}"/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
- chmod a+rx "${D}"/${CRYSTAL_PREFIX}/bin/*
-
- dodir /etc/env.d
- echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
- doenvd 90crystalspace
-}
diff --git a/dev-games/crystalspace/crystalspace-1.0.ebuild b/dev-games/crystalspace/crystalspace-1.0.ebuild
index c623a10ab148..709ff8c89cdc 100644
--- a/dev-games/crystalspace/crystalspace-1.0.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.ebuild,v 1.4 2007/02/02 06:50:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.ebuild,v 1.5 2007/02/08 07:22:32 nyhm Exp $
-MY_P=${PN}-src-${PV}
+inherit java-pkg-opt-2 multilib
+MY_P=${PN}-src-${PV}
DESCRIPTION="Portable 3D Game Development Kit written in C++"
HOMEPAGE="http://crystal.sourceforge.net/"
SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
@@ -16,32 +17,32 @@ sdl truetype vorbis wxwindows"
RDEPEND="virtual/opengl
virtual/glu
- java? ( virtual/jre )
+ java? ( >=virtual/jre-1.5 )
cg? ( media-gfx/nvidia-cg-toolkit )
- ode? ( dev-games/ode )
- cal3d? ( =media-libs/cal3d-0.11* )
+ ode? ( dev-games/ode )
+ cal3d? ( >=media-libs/cal3d-0.11 )
jpeg? ( media-libs/jpeg )
sdl? ( media-libs/libsdl )
vorbis? ( media-libs/libogg
- media-libs/libvorbis )
+ media-libs/libvorbis )
truetype? ( >=media-libs/freetype-2.1 )
alsa? ( media-libs/alsa-lib )
mng? ( media-libs/libmng )
png? ( media-libs/libpng )
wxwindows? ( x11-libs/pango
- x11-libs/wxGTK )
+ >=x11-libs/wxGTK-2.6 )
javascript? ( dev-lang/spidermonkey )
x11-libs/libXaw
x11-libs/libXxf86vm"
-
DEPEND="${RDEPEND}
3ds? ( media-libs/lib3ds )
java? ( dev-java/ant-core
- virtual/jdk )
+ >=virtual/jdk-1.5 )
dev-util/jam
- dev-lang/swig"
+ dev-lang/swig
+ dev-util/pkgconfig"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
@@ -50,7 +51,8 @@ src_unpack() {
# Removing conflicting target
sed -i -e "/^InstallDoc/d" \
Jamfile.in \
- docs/Jamfile
+ docs/Jamfile \
+ || die "sed failed"
}
src_compile() {
@@ -82,29 +84,32 @@ src_compile() {
$(use_with alsa asound)
#remove unwanted CFLAGS added by ./configure
sed -i -e '/COMPILER\.CFLAGS\.optimize/d' \
- Jamconfig
- jam || die "compile failed"
+ Jamconfig \
+ || die "sed failed"
+ jam -q || die "compile failed"
}
src_install() {
for installTarget in install_bin install_plugin install_lib \
install_include install_data install_config
do
- jam -q -s DESTDIR=${D} ${installTarget} \
+ jam -q -s DESTDIR="${D}" ${installTarget} \
|| die "jam ${installTarget} failed"
done
if use doc; then
- jam -q -s DESTDIR=${D} install_doc || die "make install failed"
+ jam -q -s DESTDIR="${D}" install_doc || die "jam install_doc failed"
fi
# Fill cache directory for the examples
+ local dir
for dir in castle flarge isomap parallaxtest partsys r3dtest stenciltest \
terrain terrainf;
do
- ${D}/usr/bin/cslight -video=null ${D}/usr/share/${PN}/data/maps/$dir;
+ "${D}"/usr/bin/cslight -video=null \
+ "${D}"/usr/share/${PN}/data/maps/${dir}
done
dodoc README docs/history* docs/todo_*
- echo "CRYSTAL_PLUGIN=/usr/lib/crystalspace" >> 90crystalspace
+ echo "CRYSTAL_PLUGIN=/usr/$(get_libdir)/crystalspace" > 90crystalspace
echo "CRYSTAL_CONFIG=/etc/crystalspace" >> 90crystalspace
doenvd 90crystalspace
}
diff --git a/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823 b/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823
deleted file mode 100644
index 28f5b394e1b8..000000000000
--- a/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 9e64e862ea334dd3391221f30236a02a crystalspace-0.99_pre20050823.tar.bz2 24423240
-RMD160 554dc478ce6d2598abfac56ffd0df03c3f8b03d7 crystalspace-0.99_pre20050823.tar.bz2 24423240
-SHA256 8f9b3d4ee36dda5f5ae9bb8b08eeda1db1e005fc22a5969323c65b0dd1f0bee1 crystalspace-0.99_pre20050823.tar.bz2 24423240