summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-26 02:06:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-26 02:06:09 +0000
commit7c240c759601f5a1f43594594c180b81a0606730 (patch)
treeae1b5c6d441c2b04f1f0d4e8205b8e62423723ed /dev-games
parentFix graphviz's built_with_use png wrong test case, thanks to Kacper Kowalik (... (diff)
downloadgentoo-2-7c240c759601f5a1f43594594c180b81a0606730.tar.gz
gentoo-2-7c240c759601f5a1f43594594c180b81a0606730.tar.bz2
gentoo-2-7c240c759601f5a1f43594594c180b81a0606730.zip
add USE flag for cegui support with patch from Adam Van Ymeren via bug #298736
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/ChangeLog7
-rw-r--r--dev-games/ogre/files/ogre-1.6.5-cegui.patch25
-rw-r--r--dev-games/ogre/ogre-1.6.5.ebuild11
3 files changed, 38 insertions, 5 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index b6578eaa8d83..9cc9539f0fca 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/ogre
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.63 2010/01/11 18:38:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.64 2010/03/26 02:06:09 mr_bones_ Exp $
+
+ 26 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> ogre-1.6.5.ebuild,
+ +files/ogre-1.6.5-cegui.patch:
+ add USE flag for cegui support with patch from Adam Van Ymeren via bug
+ #298736
*ogre-1.6.5 (11 Jan 2010)
diff --git a/dev-games/ogre/files/ogre-1.6.5-cegui.patch b/dev-games/ogre/files/ogre-1.6.5-cegui.patch
new file mode 100644
index 000000000000..7b2b66515e54
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.6.5-cegui.patch
@@ -0,0 +1,25 @@
+--- b/acinclude.m4 2008-12-30 12:00:47.000000000 -0500
++++ a/acinclude.m4 2010-03-23 00:51:13.000000000 -0400
+@@ -444,6 +439,14 @@
+ ])
+
+ AC_DEFUN([OGRE_CHECK_CEGUI], [
++AC_ARG_ENABLE(cegui,
++ AC_HELP_STRING([--disable-cegui],
++ [Don't build CEGUIRenderer, even if CEGUI is installed.]),
++ [if test x$enableval = xyes; then
++ build_cegui_sample=true
++ fi],
++ [build_cegui_sample=true])
++ if test x$build_cegui_sample = xtrue; then
+ PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.5.0,
+ [build_cegui_sample=true], [build_cegui_sample=false])
+ if test x$build_cegui_sample = xtrue; then
+@@ -459,6 +462,7 @@
+ else
+ AC_MSG_RESULT([CEGUI not available, Gui and FacialAnimation samples will not be built])
+ fi
++ fi
+ AM_CONDITIONAL([HAVE_CEGUI], [test x$build_cegui_sample = xtrue])
+ ])
+
diff --git a/dev-games/ogre/ogre-1.6.5.ebuild b/dev-games/ogre/ogre-1.6.5.ebuild
index 4deaaffb4a18..a5ec1f8d3784 100644
--- a/dev-games/ogre/ogre-1.6.5.ebuild
+++ b/dev-games/ogre/ogre-1.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.6.5.ebuild,v 1.1 2010/01/11 18:38:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.6.5.ebuild,v 1.2 2010/03/26 02:06:09 mr_bones_ Exp $
EAPI=2
inherit multilib eutils autotools flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/ogre/ogre-v${PV//./-}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc cg devil double-precision examples gtk threads"
+IUSE="cegui cg devil doc double-precision examples gtk threads"
RESTRICT="test" #139905
RDEPEND="dev-libs/zziplib
@@ -26,6 +26,7 @@ RDEPEND="dev-libs/zziplib
cg? ( media-gfx/nvidia-cg-toolkit )
devil? ( media-libs/devil )
gtk? ( x11-libs/gtk+:2 )
+ cegui? ( >=dev-games/cegui-0.5 )
threads? ( || ( >=dev-libs/boost-1.34.1 dev-libs/boost[threads] ) )"
DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto
@@ -48,7 +49,8 @@ src_prepare() {
fi
sed -i -e '/CPPUNIT/d' configure.in || die "sed failed"
epatch "${FILESDIR}"/${P}-boost.patch \
- "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-automake.patch \
+ "${FILESDIR}"/${P}-cegui.patch
eautoreconf
}
@@ -68,7 +70,8 @@ src_configure() {
$(use_enable cg) \
$(use_enable devil) \
$(use_enable double-precision double) \
- $(use_enable threads threading)
+ $(use_enable threads threading) \
+ $(use_enable cegui)
}
src_install() {