summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-09-09 09:25:36 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-09-09 09:25:36 +0000
commitd1b0ae6a2ba6d39f23d91647f8268f5304eb76bf (patch)
treeb777ff390c0fe5c495691cae5b32b8f5927fc2af /dev-games
parentUse /usr/lib instead of get_libdir for the vmhome path, bug #380853. (diff)
downloadgentoo-2-d1b0ae6a2ba6d39f23d91647f8268f5304eb76bf.tar.gz
gentoo-2-d1b0ae6a2ba6d39f23d91647f8268f5304eb76bf.tar.bz2
gentoo-2-d1b0ae6a2ba6d39f23d91647f8268f5304eb76bf.zip
Build with libpng-1.5 Bug #381723
(Portage version: 2.1.10.14/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog6
-rw-r--r--dev-games/crystalspace/crystalspace-1.4.0.ebuild5
-rw-r--r--dev-games/crystalspace/files/crystalspace-1.4.0-png15.patch56
3 files changed, 64 insertions, 3 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index ca207ecd7573..bc219d81309c 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/crystalspace
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.52 2011/07/20 13:26:19 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.53 2011/09/09 09:25:36 tupone Exp $
+
+ 09 Sep 2011; Tupone Alfredo <tupone@gentoo.org> crystalspace-1.4.0.ebuild,
+ +files/crystalspace-1.4.0-png15.patch:
+ Build with libpng-1.5 Bug #381723 by Diego Elio Pettenò
20 Jul 2011; Thomas Kahle <tomka@gentoo.org> crystalspace-1.2.1.ebuild:
Dropping to ~x86 wrt to bug 335921
diff --git a/dev-games/crystalspace/crystalspace-1.4.0.ebuild b/dev-games/crystalspace/crystalspace-1.4.0.ebuild
index fa89d37f4e5b..b874d0226e5f 100644
--- a/dev-games/crystalspace/crystalspace-1.4.0.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.4.0.ebuild,v 1.8 2011/02/25 18:34:11 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.4.0.ebuild,v 1.9 2011/09/09 09:25:36 tupone Exp $
EAPI=2
inherit eutils flag-o-matic multilib java-pkg-opt-2 autotools wxwidgets versionator
@@ -59,7 +59,8 @@ src_prepare() {
Jamfile.in \
docs/Jamfile \
|| die "sed failed"
- epatch "${FILESDIR}"/${P}-bullet.patch
+ epatch "${FILESDIR}"/${P}-bullet.patch \
+ "${FILESDIR}"/${P}-png15.patch
AT_M4DIR=mk/autoconf
eautoreconf
}
diff --git a/dev-games/crystalspace/files/crystalspace-1.4.0-png15.patch b/dev-games/crystalspace/files/crystalspace-1.4.0-png15.patch
new file mode 100644
index 000000000000..314521eaf235
--- /dev/null
+++ b/dev-games/crystalspace/files/crystalspace-1.4.0-png15.patch
@@ -0,0 +1,56 @@
+--- plugins/video/loader/png/pngimage.cpp.old 2011-09-09 10:39:57.218570796 +0200
++++ plugins/video/loader/png/pngimage.cpp 2011-09-09 10:46:45.733522309 +0200
+@@ -60,7 +60,7 @@
+
+ static void png_write (png_structp png, png_bytep data, png_size_t length)
+ {
+- datastore *ds = (datastore *)png->io_ptr;
++ datastore *ds = (datastore *)png_get_io_ptr(png);
+ if (ds->pos + (long)length > ds->length)
+ {
+ ds->data = (unsigned char*)cs_realloc (ds->data, ds->pos + (long)length);
+@@ -173,7 +173,7 @@
+ }
+
+ /* Catch processing errors */
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ /* If we get here, we had a problem reading the file */
+ png_destroy_write_struct (&png, &info);
+@@ -355,7 +355,7 @@
+ void ImagePngFile::PngLoader::ImagePngRead (png_structp png, png_bytep data,
+ png_size_t size)
+ {
+- ImagePngRawData *self = (ImagePngRawData *) png->io_ptr;
++ ImagePngRawData *self = (ImagePngRawData *) png_get_io_ptr(png);
+
+ if (self->r_size < size)
+ png_error (png, "Read Error");
+@@ -394,7 +394,7 @@
+ return false;
+ }
+
+- if (setjmp (png->jmpbuf))
++ if (setjmp (png_jmpbuf(png)))
+ {
+ nomem2:
+ // If we get here, we had a problem reading the file
+@@ -524,7 +524,7 @@
+ {
+ size_t rowbytes, exp_rowbytes;
+
+- if (setjmp (png->jmpbuf))
++ if (setjmp (png_jmpbuf(png)))
+ {
+ nomem2:
+ // If we get here, we had a problem reading the file
+@@ -560,7 +560,7 @@
+
+ png_bytep * const row_pointers = new png_bytep[Height];
+
+- if (setjmp (png->jmpbuf)) // Set a new exception handler
++ if (setjmp (png_jmpbuf(png))) // Set a new exception handler
+ {
+ delete [] row_pointers;
+ goto nomem2;