summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-19 16:46:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-19 16:46:26 +0000
commitdadbcfa8a6d1f11f96fa065df550d2c148cdfa84 (patch)
treeaa5e609cbcfa2e15dea4d2de0843f1ea5e0cb2b1 /dev-games
parentold (diff)
downloadgentoo-2-dadbcfa8a6d1f11f96fa065df550d2c148cdfa84.tar.gz
gentoo-2-dadbcfa8a6d1f11f96fa065df550d2c148cdfa84.tar.bz2
gentoo-2-dadbcfa8a6d1f11f96fa065df550d2c148cdfa84.zip
old
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/guichan-0.5.0.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-games/guichan/guichan-0.5.0.ebuild b/dev-games/guichan/guichan-0.5.0.ebuild
index 5329ce14b806..8093fd57973b 100644
--- a/dev-games/guichan/guichan-0.5.0.ebuild
+++ b/dev-games/guichan/guichan-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.5.0.ebuild,v 1.1 2006/08/20 05:11:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.5.0.ebuild,v 1.2 2006/09/19 16:46:26 mr_bones_ Exp $
inherit eutils autotools
@@ -19,24 +19,17 @@ DEPEND="opengl? ( virtual/opengl )
S=${WORKDIR}/${P}-src
-src_unpack() {
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}/${P}"-gentoo.patch
- #eautoreconf
-}
-
src_compile() {
econf \
$(use_enable allegro) \
$(use_enable sdl) \
$(use_enable sdl sdlimage) \
$(use_enable opengl) \
- || die "Configuration failed"
- emake || die "Build failed"
+ || die
+ emake || die "emake failed"
}
src_install() {
- make install DESTDIR="${D}" || die "Installation failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
}