summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-09-12 20:19:20 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-09-12 20:19:20 +0000
commita52ce2a03436033bbd1f635f3518185e4407776d (patch)
tree785bb44fbe1595e50b8173e94fe246d55ed1673a /dev-haskell/bio
parentFix memset argument (noticed by GCC). (diff)
downloadgentoo-2-a52ce2a03436033bbd1f635f3518185e4407776d.tar.gz
gentoo-2-a52ce2a03436033bbd1f635f3518185e4407776d.tar.bz2
gentoo-2-a52ce2a03436033bbd1f635f3518185e4407776d.zip
A bioinformatics library for haskell (requested by Martin MOKREJŠ).
(Portage version: 2.2.1_p20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/bio')
-rw-r--r--dev-haskell/bio/ChangeLog9
-rw-r--r--dev-haskell/bio/Manifest3
-rw-r--r--dev-haskell/bio/bio-0.5.3.ebuild61
-rw-r--r--dev-haskell/bio/metadata.xml25
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-haskell/bio/ChangeLog b/dev-haskell/bio/ChangeLog
new file mode 100644
index 000000000000..8a5d6f5e5ec9
--- /dev/null
+++ b/dev-haskell/bio/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/bio
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bio/ChangeLog,v 1.1 2013/09/12 20:19:20 slyfox Exp $
+
+*bio-0.5.3 (12 Sep 2013)
+
+ 12 Sep 2013; Sergei Trofimovich <slyfox@gentoo.org> +bio-0.5.3.ebuild,
+ +metadata.xml:
+ A bioinformatics library for haskell (requested by Martin MOKREJŠ).
diff --git a/dev-haskell/bio/Manifest b/dev-haskell/bio/Manifest
new file mode 100644
index 000000000000..954266eefce4
--- /dev/null
+++ b/dev-haskell/bio/Manifest
@@ -0,0 +1,3 @@
+DIST bio-0.5.3.tar.gz 103707 SHA256 42c8f9b83fea6bf51356afe1251910ba4421e0af0bb4f26431eaf385971d7eed SHA512 fbe09240a600abbcac952f52f05f28f9b305a1ae3def8b4144bd73bdb160acfbe5457086ef829057d5a73df1df5061668487b2ca5621df73628c8c4990b6b544 WHIRLPOOL 84d057c68b0fbf899594470e171f883b92def29f0f7f607b08d0d419dd01c5f2e0f6054f93387c32b6b7ffdd1ceb6e84ef6b8cfe5faaee1f89c2e8b10837dcb8
+EBUILD bio-0.5.3.ebuild 1375 SHA256 ecf9ceec6bda42efbdc69ff61de7537e9410c04162d553efa769c495cf4e8b98 SHA512 82fee07894b9e332aac30e82bd367c0f0c3e02f61d5ad5f5b70542244b522eba96bb83435bffb4bdff6cdffe1c8823181277be00a83fab7892a5d6e65e6534e2 WHIRLPOOL 9f3176b3586f79dc6342090b8faadabc9c1a0f34753bcf11b9080798033325bb253cd8a6a75ad7a8e8e2d3160a8297ae883b93d1b2509dc12d1df452343decd1
+MISC metadata.xml 1122 SHA256 aaafdc9895fe7b024ed53b6c43689db3d3b4521a3d1f95cfa9a4efa79a9039c6 SHA512 3ea3be892112d9141e04990e90d59a6a4605a4b884a7395ba179fe43068fb2a9c9c70cd3338ceecd615831f5474620768d529e355f72c1fedc652c82f2530841 WHIRLPOOL db24da3d68a86d0a77a825d27f8fba03aeab0235723d485b878fa7cb5473b60ea291d1541a7acd95c205cfc5b570caaa852c23a41b2a1076eecd79c16bb36c14
diff --git a/dev-haskell/bio/bio-0.5.3.ebuild b/dev-haskell/bio/bio-0.5.3.ebuild
new file mode 100644
index 000000000000..a39ab545de90
--- /dev/null
+++ b/dev-haskell/bio/bio-0.5.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bio/bio-0.5.3.ebuild,v 1.1 2013/09/12 20:19:20 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A bioinformatics library"
+HOMEPAGE="http://biohaskell.org/Libraries/Bio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples test"
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parallel:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-haskell/quickcheck-2:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/tagsoup-0.8:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'binary >=0.4 && <0.5' 'binary >=0.4 && <0.8'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag test test)
+}
+
+src_test() {
+ dist/build/qc/qc || die
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${ED}"/usr/bin/qc
+ # many examples collide with dev-haskell/flower
+ if use examples ; then
+ pushd "${ED}"/usr/bin
+ local example
+ for example in *
+ do
+ mv "${example}" "${PN}-example-${example}"
+ done
+ popd
+ fi
+}
diff --git a/dev-haskell/bio/metadata.xml b/dev-haskell/bio/metadata.xml
new file mode 100644
index 000000000000..40ea47d65060
--- /dev/null
+++ b/dev-haskell/bio/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This is a collection of data structures and algorithms
+ useful for building bioinformatics-related tools
+ and utilities.
+
+ Current list of features includes: a Sequence data type supporting
+ protein and nucleotide sequences and conversion between them. As of version
+ 0.4, different kinds of sequence have different types. Support for quality
+ data, reading and writing Fasta formatted files, reading TwoBit and
+ phd formats, and Roche/454 SFF files. Rudimentary (i.e. unoptimized) support
+ for doing alignments - including dynamic adjustment of scores based on sequence quality.
+ Also Blast output parsing. Partly implemented single linkage clustering, and
+ multiple alignment. Reading Gene Ontology (GO) annotations (GOA) and
+ definitions\/hierarchy.
+
+ The Darcs repository is at: &lt;http://malde.org/~ketil/biohaskell/biolib&gt;.
+ </longdescription>
+</pkgmetadata>