summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-11-14 22:35:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-11-14 22:35:43 +0000
commit767b4a695a01034a1f2a006b3fba942ff2fe4826 (patch)
tree05b140bffbd2323f1e385a4c53314c74419d5600 /dev-haskell/cabal/cabal-1.16.0.3.ebuild
parentMake the generator script more usable (diff)
downloadgentoo-2-767b4a695a01034a1f2a006b3fba942ff2fe4826.tar.gz
gentoo-2-767b4a695a01034a1f2a006b3fba942ff2fe4826.tar.bz2
gentoo-2-767b4a695a01034a1f2a006b3fba942ff2fe4826.zip
Version bump.
(Portage version: 2.2.0_alpha142_p19/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/cabal/cabal-1.16.0.3.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-1.16.0.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-1.16.0.3.ebuild b/dev-haskell/cabal/cabal-1.16.0.3.ebuild
new file mode 100644
index 000000000000..cfc5a18682dd
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.16.0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.16.0.3.ebuild,v 1.1 2012/11/14 22:35:43 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bootstrap lib profile test-suite"
+inherit haskell-cabal eutils versionator
+
+MY_PN="Cabal"
+MY_PV=$(get_version_component_range '1-4')
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/extensible-exceptions
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.1.0.1
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ )"
+
+RESTRICT="test" # Fails own tests
+
+RDEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# cabal uses dev-util/pkgconfig using runtime to resolve C dependencies, so
+# repoman's RDEPEND.suspect QA does not apply here
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_configure() {
+ if ! cabal-is-dummy-lib; then
+ einfo "Bootstrapping Cabal..."
+ $(ghc-getghc) ${HCFLAGS} -i -i. -i"${WORKDIR}/${FP_P}" -cpp --make Setup.hs \
+ -o setup || die "compiling Setup.hs failed"
+ cabal-configure
+ fi
+}
+
+src_compile() {
+ if ! cabal-is-dummy-lib; then
+ cabal-build
+ fi
+}