summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-03-07 17:55:10 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-03-07 17:55:10 +0000
commitfe363d5fdf9edab00a656b2cfc5894e670e8abe9 (patch)
tree19800c0adce71475afaef48881f7161cd869bff2 /dev-haskell/cabal
parentRemove broken version. Does not compile with GCC 3.4, or 4.x. (diff)
downloadgentoo-2-fe363d5fdf9edab00a656b2cfc5894e670e8abe9.tar.gz
gentoo-2-fe363d5fdf9edab00a656b2cfc5894e670e8abe9.tar.bz2
gentoo-2-fe363d5fdf9edab00a656b2cfc5894e670e8abe9.zip
Bump version of dev-haskell/cabal to 1.1.6.1. (needed for dev-lang/ghc-6.6)
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-haskell/cabal')
-rw-r--r--dev-haskell/cabal/ChangeLog9
-rw-r--r--dev-haskell/cabal/cabal-1.1.6.1.ebuild50
-rw-r--r--dev-haskell/cabal/files/digest-cabal-1.1.6.13
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index f4912e16b663..b9a7cedfb014 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cabal
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.24 2006/10/12 19:06:05 dcoutts Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.25 2007/03/07 17:55:10 kolmodin Exp $
+
+*cabal-1.1.6.1 (07 Mar 2007)
+
+ 07 Mar 2007; <kolmodin@gentoo.org> +cabal-1.1.6.1.ebuild:
+ Bump version, it's a dependency of dev-lang/ghc-6.6.
12 Oct 2006; Duncan Coutts <dcoutts@gentoo.org> -cabal-1.1.3.ebuild,
cabal-1.1.3-r1.ebuild, cabal-1.1.4.ebuild:
diff --git a/dev-haskell/cabal/cabal-1.1.6.1.ebuild b/dev-haskell/cabal/cabal-1.1.6.1.ebuild
new file mode 100644
index 000000000000..6a23aff21ea1
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.1.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.1.ebuild,v 1.1 2007/03/07 17:55:10 kolmodin Exp $
+
+CABAL_FEATURES="bootstrap profile lib"
+inherit haskell-cabal eutils
+
+DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
+HOMEPAGE="http://haskell.org/cabal"
+SRC_URI="http://haskell.org/cabal/release/${P}/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc"
+
+DEPEND=">=virtual/ghc-6.2"
+
+src_unpack() {
+ unpack "${A}"
+ if ! $(ghc-cabal); then
+ sed -i 's/Build-Depends: base/Build-Depends: base, unix/' \
+ ${S}/Cabal.cabal
+ fi
+}
+
+src_compile() {
+ if ghc-cabal; then
+ make setup HC="$(ghc-getghc) -ignore-package Cabal"
+ else
+ make setup HC="$(ghc-getghc)"
+ fi
+ cabal-configure
+ cabal-build
+}
+
+src_install() {
+ cabal_src_install
+
+ # documentation (install directly)
+ dohtml -r doc/users-guide
+ if use doc; then
+ dohtml -r doc/API
+ dohtml -r doc/pkg-spec-html
+ dodoc doc/pkg-spec.pdf
+ fi
+ dodoc changelog copyright README releaseNotes TODO
+}
+
diff --git a/dev-haskell/cabal/files/digest-cabal-1.1.6.1 b/dev-haskell/cabal/files/digest-cabal-1.1.6.1
new file mode 100644
index 000000000000..b469b4b25f2a
--- /dev/null
+++ b/dev-haskell/cabal/files/digest-cabal-1.1.6.1
@@ -0,0 +1,3 @@
+MD5 5712226383de78365e75092f8f5f5e7b cabal-1.1.6.1.tar.gz 440851
+RMD160 82e85e57f2747f7b38f68e6d11883252e83838e8 cabal-1.1.6.1.tar.gz 440851
+SHA256 b59ce863c31bee561ca5d5ab2aa996856f8fc1b6297848868fc4f635d716b04e cabal-1.1.6.1.tar.gz 440851