summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-14 18:22:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-14 18:22:22 +0000
commit1fbff6113f32402d98231926dd918fc8c864db39 (patch)
tree248358aecf6d59bc85881c59ce462e2c753d41e8 /dev-haskell/certificate/certificate-1.3.9.ebuild
parentVersion bump. (diff)
downloadgentoo-2-1fbff6113f32402d98231926dd918fc8c864db39.tar.gz
gentoo-2-1fbff6113f32402d98231926dd918fc8c864db39.tar.bz2
gentoo-2-1fbff6113f32402d98231926dd918fc8c864db39.zip
Version bump.
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/certificate/certificate-1.3.9.ebuild')
-rw-r--r--dev-haskell/certificate/certificate-1.3.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/certificate/certificate-1.3.9.ebuild b/dev-haskell/certificate/certificate-1.3.9.ebuild
new file mode 100644
index 000000000000..75195370be85
--- /dev/null
+++ b/dev-haskell/certificate/certificate-1.3.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/certificate/certificate-1.3.9.ebuild,v 1.1 2013/11/14 18:22:22 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Certificates and Key Reader/Writer"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable test"
+RESTRICT="test" # due missing tests
+
+RDEPEND=">=dev-haskell/asn1-data-0.7.1:=[profile?] <dev-haskell/asn1-data-0.8.0:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ executable? ( dev-haskell/cmdargs:=[profile?]
+ dev-haskell/crypto-pubkey:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag test test)
+}