summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 05:49:34 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 05:49:34 +0000
commit77ac361f425656f993db28c2f7f271a84ccecff1 (patch)
treea2e399ffc773a2a89617e3970603165bb973f926 /dev-haskell/connection
parentBump conduit to 1.0.9.3 (diff)
downloadgentoo-2-77ac361f425656f993db28c2f7f271a84ccecff1.tar.gz
gentoo-2-77ac361f425656f993db28c2f7f271a84ccecff1.tar.bz2
gentoo-2-77ac361f425656f993db28c2f7f271a84ccecff1.zip
Add connection
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/connection')
-rw-r--r--dev-haskell/connection/ChangeLog9
-rw-r--r--dev-haskell/connection/connection-0.1.3.1.ebuild37
-rw-r--r--dev-haskell/connection/metadata.xml16
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/connection/ChangeLog b/dev-haskell/connection/ChangeLog
new file mode 100644
index 000000000000..e084425feb8a
--- /dev/null
+++ b/dev-haskell/connection/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/connection
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/connection/ChangeLog,v 1.1 2013/12/11 05:49:34 gienah Exp $
+
+*connection-0.1.3.1 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +connection-0.1.3.1.ebuild,
+ +metadata.xml:
+ Add connection
diff --git a/dev-haskell/connection/connection-0.1.3.1.ebuild b/dev-haskell/connection/connection-0.1.3.1.ebuild
new file mode 100644
index 000000000000..e54c79e218a9
--- /dev/null
+++ b/dev-haskell/connection/connection-0.1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/connection/connection-0.1.3.1.ebuild,v 1.1 2013/12/11 05:49:34 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple and easy network connections API"
+HOMEPAGE="http://github.com/vincenthz/hs-connection"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/certificate-1.3.0:=[profile?] <dev-haskell/certificate-1.4.0:=[profile?]
+ dev-haskell/cprng-aes:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/socks-0.4:=[profile?]
+ >=dev-haskell/tls-1.0:=[profile?] <dev-haskell/tls-1.2:=[profile?]
+ >=dev-haskell/tls-extra-0.5:=[profile?] <dev-haskell/tls-extra-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/connection/metadata.xml b/dev-haskell/connection/metadata.xml
new file mode 100644
index 000000000000..f24b16619688
--- /dev/null
+++ b/dev-haskell/connection/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Simple network library for all your connection need.
+
+ Features: Really simple to use, SSL/TLS, SOCKS.
+
+ This library provides a very simple api to create sockets
+ to a destination with the choice of SSL/TLS, and SOCKS.
+ </longdescription>
+</pkgmetadata>