summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 12:09:34 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 12:09:34 +0000
commit86b95ba834383c665b6f7a48900d05fc6fb54f2c (patch)
tree2cb8d7b5d0f659a819ef054c007458e2d85930a2 /dev-haskell/distributive
parentBump lens to 3.10 (diff)
downloadgentoo-2-86b95ba834383c665b6f7a48900d05fc6fb54f2c.tar.gz
gentoo-2-86b95ba834383c665b6f7a48900d05fc6fb54f2c.tar.bz2
gentoo-2-86b95ba834383c665b6f7a48900d05fc6fb54f2c.zip
Bump distributive to 0.3.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/distributive')
-rw-r--r--dev-haskell/distributive/ChangeLog8
-rw-r--r--dev-haskell/distributive/distributive-0.3.2.ebuild33
-rw-r--r--dev-haskell/distributive/metadata.xml3
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/distributive/ChangeLog b/dev-haskell/distributive/ChangeLog
index 17ff795813d4..71d97d8983b8 100644
--- a/dev-haskell/distributive/ChangeLog
+++ b/dev-haskell/distributive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/distributive
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/distributive/ChangeLog,v 1.1 2013/08/26 10:07:21 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/distributive/ChangeLog,v 1.2 2013/10/19 12:09:34 gienah Exp $
+
+*distributive-0.3.2 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +distributive-0.3.2.ebuild,
+ metadata.xml:
+ Bump distributive to 0.3.2
*distributive-0.3.1 (26 Aug 2013)
diff --git a/dev-haskell/distributive/distributive-0.3.2.ebuild b/dev-haskell/distributive/distributive-0.3.2.ebuild
new file mode 100644
index 000000000000..ea6597ed713a
--- /dev/null
+++ b/dev-haskell/distributive/distributive-0.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/distributive/distributive-0.3.2.ebuild,v 1.1 2013/10/19 12:09:33 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell 98 Distributive functors -- Dual to Traversable"
+HOMEPAGE="http://github.com/ekmett/distributive/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-werror"
+
+RDEPEND=">=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-compat-0.1:=[profile?] <dev-haskell/transformers-compat-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.9.1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-werror lib-werror)
+}
diff --git a/dev-haskell/distributive/metadata.xml b/dev-haskell/distributive/metadata.xml
index cae9b830e2c5..276d66474572 100644
--- a/dev-haskell/distributive/metadata.xml
+++ b/dev-haskell/distributive/metadata.xml
@@ -8,4 +8,7 @@
<longdescription>
Haskell 98 Distributive functors -- Dual to Traversable
</longdescription>
+<use>
+ <flag name='lib-werror'>Compile with the ghc -Werror option</flag>
+</use>
</pkgmetadata>