summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-13 13:53:07 +0000
committerMark Wright <gienah@gentoo.org>2014-12-13 13:53:07 +0000
commit6750b5e20ade22ffe0d0d4649a964719a1a01975 (patch)
treeb7bd78f1bd605372f45683335599556cfd413c72 /dev-haskell/glib
parentBump crypto-random to 0.0.8 (diff)
downloadgentoo-2-6750b5e20ade22ffe0d0d4649a964719a1a01975.tar.gz
gentoo-2-6750b5e20ade22ffe0d0d4649a964719a1a01975.tar.bz2
gentoo-2-6750b5e20ade22ffe0d0d4649a964719a1a01975.zip
Bump glib to 0.13.0.6
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/glib')
-rw-r--r--dev-haskell/glib/ChangeLog7
-rw-r--r--dev-haskell/glib/glib-0.13.0.6.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-haskell/glib/ChangeLog b/dev-haskell/glib/ChangeLog
index 90b2bacaff3b..eb65f1c363e9 100644
--- a/dev-haskell/glib/ChangeLog
+++ b/dev-haskell/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/glib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/ChangeLog,v 1.26 2014/07/25 09:16:22 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/ChangeLog,v 1.27 2014/12/13 13:53:07 gienah Exp $
+
+*glib-0.13.0.6 (13 Dec 2014)
+
+ 13 Dec 2014; Mark Wright <gienah@gentoo.org> +glib-0.13.0.6.ebuild:
+ Bump glib to 0.13.0.6
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> glib-0.12.0.ebuild,
glib-0.12.3.1.ebuild, glib-0.12.4-r1.ebuild, glib-0.12.5.0-r1.ebuild,
diff --git a/dev-haskell/glib/glib-0.13.0.6.ebuild b/dev-haskell/glib/glib-0.13.0.6.ebuild
new file mode 100644
index 000000000000..8abbf8fa8ee2
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/glib-0.13.0.6.ebuild,v 1.1 2014/12/13 13:53:07 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+closure_signals"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-lang/ghc-7.8.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure_signals closure_signals)
+}