summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-02 11:50:37 +0000
committerMark Wright <gienah@gentoo.org>2013-04-02 11:50:37 +0000
commit30a4c0f293534294ce2a4c62ea49fdfd2db1577d (patch)
treecf827af865bbd2e0b8ebaca6b6e6eddac0ce9e8e /dev-haskell/highlighting-kate
parentAdd file-embed (diff)
downloadgentoo-2-30a4c0f293534294ce2a4c62ea49fdfd2db1577d.tar.gz
gentoo-2-30a4c0f293534294ce2a4c62ea49fdfd2db1577d.tar.bz2
gentoo-2-30a4c0f293534294ce2a4c62ea49fdfd2db1577d.zip
Bump highlighting-kate to 0.5.3.8
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/highlighting-kate')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog8
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.3.8.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index ebe12c306170..2862af77d713 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.8 2013/02/09 19:21:10 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.9 2013/04/02 11:50:37 gienah Exp $
+
+*highlighting-kate-0.5.3.8 (02 Apr 2013)
+
+ 02 Apr 2013; Mark Wright <gienah@gentoo.org>
+ +highlighting-kate-0.5.3.8.ebuild:
+ Bump highlighting-kate to 0.5.3.8
*highlighting-kate-0.5.3.5 (09 Feb 2013)
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.8.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.8.ebuild
new file mode 100644
index 000000000000..74ba9bb61bb7
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.8.ebuild,v 1.1 2013/04/02 11:50:37 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?]
+ <dev-haskell/blaze-html-0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ pcre-light? ( =dev-haskell/pcre-light-0.4*:=[profile?]
+ )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}