summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-24 14:24:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-24 14:24:01 +0000
commitfd75c2c595ef00379b446a87488b4a7532ac6e16 (patch)
treede6600d17822377898d2d4ba8baf1625bad33658 /dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-fd75c2c595ef00379b446a87488b4a7532ac6e16.tar.gz
gentoo-2-fd75c2c595ef00379b446a87488b4a7532ac6e16.tar.bz2
gentoo-2-fd75c2c595ef00379b446a87488b4a7532ac6e16.zip
Initial version. lifted IO operations from the base library. A depend of >=dev-vcs/git-annex-3.20120315.
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild')
-rw-r--r--dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild b/dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild
new file mode 100644
index 000000000000..0fb44cdd6fa9
--- /dev/null
+++ b/dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lifted-base/lifted-base-0.1.0.3-r1.ebuild,v 1.1 2012/03/24 14:24:01 slyfox Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="lifted IO operations from the base library"
+HOMEPAGE="https://github.com/basvandijk/lifted-base"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/base-unicode-symbols-0.1.1[profile?] <dev-haskell/base-unicode-symbols-0.3[profile?]
+ =dev-haskell/monad-control-0.3*[profile?]
+ =dev-haskell/transformers-base-0.4*[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( dev-haskell/hunit
+ <dev-haskell/test-framework-0.7
+ <dev-haskell/test-framework-hunit-0.3
+ )"
+
+PATCHES=("${FILESDIR}/${PN}-0.1.0.1-test-ghc-6.12.patch")
+
+src_prepare() {
+ base_src_prepare
+ sed -e 's@test-framework >= 0.2.4 && < 0.5@test-framework >= 0.2.4 \&\& < 0.7@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen dependencies"
+}
+
+src_configure() {
+ cabal_src_configure $(use_enable test tests)
+}