summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-05-05 13:06:05 +0000
committerMark Wright <gienah@gentoo.org>2012-05-05 13:06:05 +0000
commit088bb92f9720a51f4d08262e89a2c6422780e983 (patch)
tree76ff6d9619670bde4c8e86ded68d8bdc18eefcc8 /dev-haskell
parentAdd keywords for darcs 2.8.0. [profile?] for haskell libs (part of fix for bu... (diff)
downloadgentoo-2-088bb92f9720a51f4d08262e89a2c6422780e983.tar.gz
gentoo-2-088bb92f9720a51f4d08262e89a2c6422780e983.tar.bz2
gentoo-2-088bb92f9720a51f4d08262e89a2c6422780e983.zip
Add cmdlib for darcs 2.8.0 tests
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cmdlib/ChangeLog10
-rw-r--r--dev-haskell/cmdlib/cmdlib-0.3.5.ebuild27
-rw-r--r--dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch16
-rw-r--r--dev-haskell/cmdlib/metadata.xml31
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/cmdlib/ChangeLog b/dev-haskell/cmdlib/ChangeLog
new file mode 100644
index 000000000000..cbc3073fe31a
--- /dev/null
+++ b/dev-haskell/cmdlib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/cmdlib
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cmdlib/ChangeLog,v 1.1 2012/05/05 13:06:05 gienah Exp $
+
+*cmdlib-0.3.5 (05 May 2012)
+
+ 05 May 2012; Mark Wright <gienah@gentoo.org>
+ +files/cmdlib-0.3.4-ghc-6.12.patch, +cmdlib-0.3.5.ebuild, +metadata.xml:
+ Add cmdlib for darcs 2.8.0 tests
+
diff --git a/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild b/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild
new file mode 100644
index 000000000000..1961417184c3
--- /dev/null
+++ b/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cmdlib/cmdlib-0.3.5.ebuild,v 1.1 2012/05/05 13:06:05 gienah Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="a library for command line parsing & online help"
+HOMEPAGE="http://hackage.haskell.org/package/cmdlib"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl
+ dev-haskell/split
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+PATCHES=("${FILESDIR}/${PN}-0.3.4-ghc-6.12.patch")
diff --git a/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch b/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch
new file mode 100644
index 000000000000..85a19d9aff02
--- /dev/null
+++ b/dev-haskell/cmdlib/files/cmdlib-0.3.4-ghc-6.12.patch
@@ -0,0 +1,16 @@
+--- cmdlib-0.3.4-orig/System/Console/CmdLib/Command.hs 2011-10-07 07:19:48.000000000 +1100
++++ cmdlib-0.3.4/System/Console/CmdLib/Command.hs 2012-01-06 20:49:59.668959773 +1100
+@@ -225,6 +225,13 @@
+ commandGroup :: (Commands a) => String -> a -> [CommandWrap]
+ commandGroup s l = [CommandGroup s (toCommands l)]
+
++#if !MIN_VERSION_mtl(2,0,0)
++instance Monad (Either e) where
++ return = Right
++ Left l >>= _ = Left l
++ Right r >>= k = k r
++#endif
++
+ -- TODO: disambiguation, hidden commands (aliases)
+ findCommand :: String -> [CommandWrap] -> [CommandWrap]
+ findCommand key list = case accum list of Left x -> [x]
diff --git a/dev-haskell/cmdlib/metadata.xml b/dev-haskell/cmdlib/metadata.xml
new file mode 100644
index 000000000000..ea1fb11634b1
--- /dev/null
+++ b/dev-haskell/cmdlib/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A commandline parsing library, based on getopt. Comes with a
+ powerful attribute system. Supports complex interfaces with many
+ options and commands, with option &amp; command grouping, with simple
+ and convenient API. Even though quite powerful, it strives to keep
+ simple things simple. The library uses &quot;System.Console.GetOpt&quot; as
+ its backend.
+
+ In comparison to the other commandline handling libraries:
+
+ Compared to cmdargs, cmdlib has a pure attribute system and is
+ based on GetOpt for help formatting &amp; argument parsing. Cmdlib may
+ also be more extendable due to typeclass design, and can use
+ user-supplied types for option arguments.
+
+ Cmdargs &gt;= 0.4 can optionally use a pure attribute system,
+ although this is clearly an add-on and the API is a second-class
+ citizen in relation to the impure version.
+
+ GetOpt and parseargs both require explicit flag representation, so
+ they live a level below cmdlib. GetOpt is in fact used as a
+ backend by cmdlib.
+ </longdescription>
+</pkgmetadata>