summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-02-13 21:26:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-02-13 21:26:15 +0000
commit27680f920d3dd55e640967e07b226d2e057e47c2 (patch)
tree6e3e87c3d9394e10c20857eb5450565283de0fa8 /dev-haskell
parentEAPI=5; compile warning patch (diff)
downloadgentoo-2-27680f920d3dd55e640967e07b226d2e057e47c2.tar.gz
gentoo-2-27680f920d3dd55e640967e07b226d2e057e47c2.tar.bz2
gentoo-2-27680f920d3dd55e640967e07b226d2e057e47c2.zip
Fixed build failure against 'USE=tinfo ncurses' in bug #454216 by Reinis Danne.
(Portage version: 2.2.0_alpha161_p21/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/terminfo/ChangeLog10
-rw-r--r--dev-haskell/terminfo/files/terminfo-0.3.2.5-tinfo.patch25
-rw-r--r--dev-haskell/terminfo/terminfo-0.3.1.1.ebuild19
-rw-r--r--dev-haskell/terminfo/terminfo-0.3.1.3.ebuild25
-rw-r--r--dev-haskell/terminfo/terminfo-0.3.2.5.ebuild12
5 files changed, 42 insertions, 49 deletions
diff --git a/dev-haskell/terminfo/ChangeLog b/dev-haskell/terminfo/ChangeLog
index 643fdd033e42..b1ac25befa1d 100644
--- a/dev-haskell/terminfo/ChangeLog
+++ b/dev-haskell/terminfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/terminfo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/terminfo/ChangeLog,v 1.25 2012/11/25 06:08:50 gienah Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/terminfo/ChangeLog,v 1.26 2013/02/13 21:26:15 slyfox Exp $
+
+ 13 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/terminfo-0.3.2.5-tinfo.patch, -terminfo-0.3.1.1.ebuild,
+ -terminfo-0.3.1.3.ebuild, terminfo-0.3.2.5.ebuild:
+ Fixed build failure against 'USE=tinfo ncurses' in bug #454216 by Reinis
+ Danne.
*terminfo-0.3.2.5 (25 Nov 2012)
diff --git a/dev-haskell/terminfo/files/terminfo-0.3.2.5-tinfo.patch b/dev-haskell/terminfo/files/terminfo-0.3.2.5-tinfo.patch
new file mode 100644
index 000000000000..ca10da2e03ae
--- /dev/null
+++ b/dev-haskell/terminfo/files/terminfo-0.3.2.5-tinfo.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/454216
+
+Mon Jan 7 16:34:47 FET 2013 Judah Jacobson <judah.jacobson@gmail.com>
+ * Search for terminfo in libtinfo; fixes GHC #7281.
+
+ Patch from Paul Johnson.
+diff -rN -u old-terminfo/configure.ac new-terminfo/configure.ac
+--- old-terminfo/configure.ac 2013-02-14 00:16:11.816111434 +0300
++++ new-terminfo/configure.ac 2013-02-14 00:16:11.819111434 +0300
+@@ -39,10 +39,11 @@
+ TERMINFO_INCLUDES="$CursesIncludes term.h"
+ fi
+
+-AC_CHECK_LIB(ncursesw, setupterm, HaveLibCurses=YES; LibCurses=ncursesw,
+- [AC_CHECK_LIB(ncurses, setupterm, HaveLibCurses=YES; LibCurses=ncurses,
+- [AC_CHECK_LIB(curses, setupterm, HaveLibCurses=YES; LibCurses=curses,
+- HaveLibCurses=NO; LibCurses=not-installed)])])
++AC_CHECK_LIB(tinfo, setupterm, HaveLibCurses=YES; LibCurses=tinfo,
++ [AC_CHECK_LIB(ncursesw, setupterm, HaveLibCurses=YES; LibCurses=ncursesw,
++ [AC_CHECK_LIB(ncurses, setupterm, HaveLibCurses=YES; LibCurses=ncurses,
++ [AC_CHECK_LIB(curses, setupterm, HaveLibCurses=YES; LibCurses=curses,
++ HaveLibCurses=NO; LibCurses=not-installed)])])])
+
+ if test "x$HaveLibCurses" = "xNO" ; then
+ AC_MSG_FAILURE([curses library not found, so this package cannot be built])
diff --git a/dev-haskell/terminfo/terminfo-0.3.1.1.ebuild b/dev-haskell/terminfo/terminfo-0.3.1.1.ebuild
deleted file mode 100644
index cae7ab6d3f25..000000000000
--- a/dev-haskell/terminfo/terminfo-0.3.1.1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/terminfo/terminfo-0.3.1.1.ebuild,v 1.12 2012/09/12 15:34:53 qnikst Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal
-
-DESCRIPTION="Haskell bindings to the terminfo library."
-HOMEPAGE="http://code.haskell.org/terminfo"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
-IUSE=""
-
-DEPEND=">=dev-lang/ghc-6.10
- >=dev-haskell/cabal-1.4
- sys-libs/ncurses"
diff --git a/dev-haskell/terminfo/terminfo-0.3.1.3.ebuild b/dev-haskell/terminfo/terminfo-0.3.1.3.ebuild
deleted file mode 100644
index f48292284c3d..000000000000
--- a/dev-haskell/terminfo/terminfo-0.3.1.3.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/terminfo/terminfo-0.3.1.3.ebuild,v 1.7 2012/09/12 15:34:53 qnikst Exp $
-
-# ebuild generated by hackport 0.2.13
-
-EAPI="3"
-
-CABAL_FEATURES="lib profile haddock hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Haskell bindings to the terminfo library."
-HOMEPAGE="http://code.haskell.org/terminfo"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-6.10.3
- sys-libs/ncurses"
-
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.4"
diff --git a/dev-haskell/terminfo/terminfo-0.3.2.5.ebuild b/dev-haskell/terminfo/terminfo-0.3.2.5.ebuild
index b48bc66bed77..50d838ba4b6e 100644
--- a/dev-haskell/terminfo/terminfo-0.3.2.5.ebuild
+++ b/dev-haskell/terminfo/terminfo-0.3.2.5.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/terminfo/terminfo-0.3.2.5.ebuild,v 1.1 2012/11/25 06:08:50 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/terminfo/terminfo-0.3.2.5.ebuild,v 1.2 2013/02/13 21:26:15 slyfox Exp $
EAPI=5
# ebuild generated by hackport 0.3.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
+inherit autotools eutils haskell-cabal
DESCRIPTION="Haskell bindings to the terminfo library."
HOMEPAGE="http://code.haskell.org/terminfo"
@@ -22,3 +22,9 @@ RDEPEND=">=dev-lang/ghc-6.10.4:=
sys-libs/ncurses"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.4"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+
+ eautoreconf
+}