summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2006-10-14 14:11:32 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2006-10-14 14:11:32 +0000
commit2f0764a7b2040bbe42f680c0aa5f45134382ea0e (patch)
treef1b13fd650e27b0465a67d8da4659a9fd36e09ab /dev-haskell
parentAdd 2.6.18 compatibility patch, tested by Phillip Berndt and Simonas Leleiva ... (diff)
downloadgentoo-2-2f0764a7b2040bbe42f680c0aa5f45134382ea0e.tar.gz
gentoo-2-2f0764a7b2040bbe42f680c0aa5f45134382ea0e.tar.bz2
gentoo-2-2f0764a7b2040bbe42f680c0aa5f45134382ea0e.zip
Made dev-haskell/hs-plugins-* block on >=virtual/ghc-6.6
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hs-plugins/ChangeLog6
-rw-r--r--dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild3
-rw-r--r--dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild8
3 files changed, 14 insertions, 3 deletions
diff --git a/dev-haskell/hs-plugins/ChangeLog b/dev-haskell/hs-plugins/ChangeLog
index 25bd32749cca..69df6ee1f6f9 100644
--- a/dev-haskell/hs-plugins/ChangeLog
+++ b/dev-haskell/hs-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/hs-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/ChangeLog,v 1.12 2006/10/06 10:28:34 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/ChangeLog,v 1.13 2006/10/14 14:11:32 kolmodin Exp $
+
+ 14 Oct 2006; <kolmodin@gentoo.org> hs-plugins-0.9.10-r1.ebuild,
+ hs-plugins-1.0_rc0.ebuild:
+ Made all hs-plugins block on ghc-6.6
*hs-plugins-1.0_rc0 (06 Oct 2006)
diff --git a/dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild b/dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild
index b39fd8fdbacc..941663e4c9bc 100644
--- a/dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild
+++ b/dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild,v 1.4 2006/03/11 00:21:58 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/hs-plugins-0.9.10-r1.ebuild,v 1.5 2006/10/14 14:11:32 kolmodin Exp $
inherit ghc-package
@@ -15,6 +15,7 @@ KEYWORDS="-amd64 ~ppc ~sparc ~x86" # currently broken on amd64
IUSE="doc"
DEPEND="virtual/ghc
+ !>=virtual/ghc-6.6
>=dev-haskell/haskell-src-exts-0.2
dev-haskell/cabal"
diff --git a/dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild b/dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild
index f04dc53aea33..54c637f2e274 100644
--- a/dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild
+++ b/dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild,v 1.2 2006/10/06 11:46:42 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/hs-plugins-1.0_rc0.ebuild,v 1.3 2006/10/14 14:11:32 kolmodin Exp $
CABAL_FEATURES="lib"
@@ -17,7 +17,9 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="doc"
+
DEPEND="virtual/ghc
+ !>=virtual/ghc-6.6
>=dev-haskell/haskell-src-exts-0.2
dev-haskell/cabal"
@@ -25,10 +27,13 @@ S="${WORKDIR}/${PN}"
src_unpack() {
base_src_unpack
+
# use hsx
mv "${S}/plugins.cabal.hsx" "${S}/plugins.cabal"
+
# remove warning
sed -i -e "s/hs-source-dir/hs-source-dirs/" "${S}/plugins.cabal"
+
chmod +x "${S}/configure"
}
@@ -42,5 +47,6 @@ src_compile() {
src_install() {
haskell-cabal_src_install
+
dodoc README LICENSE AUTHORS
}