summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-03-10 21:58:41 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-03-10 21:58:41 +0000
commit377a840e37bbb736957bdb27d63991ff029f9d6b (patch)
treedb34fe0e97c626b1ef28a1e3bbe3f8f768e8b938 /dev-haskell
parentA bioinformatics library for haskell (requested by Martin MOKREJŠ). (diff)
downloadgentoo-2-377a840e37bbb736957bdb27d63991ff029f9d6b.tar.gz
gentoo-2-377a840e37bbb736957bdb27d63991ff029f9d6b.tar.bz2
gentoo-2-377a840e37bbb736957bdb27d63991ff029f9d6b.zip
A bioinformatics library for haskell (requested by Martin MOKREJŠ).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/biosff/ChangeLog9
-rw-r--r--dev-haskell/biosff/biosff-0.3.7.1.ebuild36
-rw-r--r--dev-haskell/biosff/metadata.xml15
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/biosff/ChangeLog b/dev-haskell/biosff/ChangeLog
new file mode 100644
index 000000000000..7fa79a697550
--- /dev/null
+++ b/dev-haskell/biosff/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/biosff
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/biosff/ChangeLog,v 1.1 2015/03/10 21:58:41 slyfox Exp $
+
+*biosff-0.3.7.1 (10 Mar 2015)
+
+ 10 Mar 2015; Sergei Trofimovich <slyfox@gentoo.org> +biosff-0.3.7.1.ebuild,
+ +metadata.xml:
+ A bioinformatics library for haskell (requested by Martin MOKREJŠ).
diff --git a/dev-haskell/biosff/biosff-0.3.7.1.ebuild b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
new file mode 100644
index 000000000000..2bff9d66d9ed
--- /dev/null
+++ b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/biosff/biosff-0.3.7.1.ebuild,v 1.1 2015/03/10 21:58:41 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Library and executables for working with SFF files"
+HOMEPAGE="http://biohaskell.org/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fclip +flower +frecover"
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ >=dev-haskell/biocore-0.3:=[profile?]
+ dev-haskell/cmdargs:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag fclip fclip) \
+ $(cabal_flag flower flower) \
+ $(cabal_flag frecover frecover)
+}
diff --git a/dev-haskell/biosff/metadata.xml b/dev-haskell/biosff/metadata.xml
new file mode 100644
index 000000000000..714e2ad3539d
--- /dev/null
+++ b/dev-haskell/biosff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The library contains the functionality for reading and writing
+ SFF files (sequencing data from 454 and Ion Torrent). It duplicates
+ code from (and is incompatible with) the &quot;bio&quot; library.
+ </longdescription>
+ <use>
+ <flag name="fclip">Build the fclip executable.</flag>
+ <flag name="flower">Build the flower executable.</flag>
+ <flag name="frecover">Build the frecover executable.</flag>
+ </use>
+</pkgmetadata>