summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-04-17 19:42:55 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-04-17 19:42:55 +0000
commit3c4ea96e006482289fe81831ac3b0c4d01d8ab09 (patch)
tree9e54ae1d51520be28491468b8f6a43d1fe24917e /dev-haskell
parentMarking youtube-dl-2012.01.08 ppc64 for bug 409753 (diff)
downloadgentoo-2-3c4ea96e006482289fe81831ac3b0c4d01d8ab09.tar.gz
gentoo-2-3c4ea96e006482289fe81831ac3b0c4d01d8ab09.tar.bz2
gentoo-2-3c4ea96e006482289fe81831ac3b0c4d01d8ab09.zip
Fixed build breakage against ghc-7.4 (bug #412289 by Robin Johnson).
(Portage version: 2.2.0_alpha100_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/crypto/ChangeLog6
-rw-r--r--dev-haskell/crypto/crypto-4.2.4.ebuild6
-rw-r--r--dev-haskell/crypto/files/crypto-4.2.4-ghc-7.4.patch27
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-haskell/crypto/ChangeLog b/dev-haskell/crypto/ChangeLog
index 69da5d2c987a..0f63d1d10a80 100644
--- a/dev-haskell/crypto/ChangeLog
+++ b/dev-haskell/crypto/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/crypto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/ChangeLog,v 1.2 2012/03/16 21:48:59 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/ChangeLog,v 1.3 2012/04/17 19:42:55 slyfox Exp $
+
+ 17 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/crypto-4.2.4-ghc-7.4.patch, crypto-4.2.4.ebuild:
+ Fixed build breakage against ghc-7.4 (bug #412289 by Robin Johnson).
16 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> crypto-4.2.4.ebuild:
Fixed case in HOMEPAGE.
diff --git a/dev-haskell/crypto/crypto-4.2.4.ebuild b/dev-haskell/crypto/crypto-4.2.4.ebuild
index 84a473c6a957..0dc0a73b1f18 100644
--- a/dev-haskell/crypto/crypto-4.2.4.ebuild
+++ b/dev-haskell/crypto/crypto-4.2.4.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/crypto-4.2.4.ebuild,v 1.2 2012/03/16 21:48:59 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/crypto-4.2.4.ebuild,v 1.3 2012/04/17 19:42:55 slyfox Exp $
# ebuild generated by hackport 0.2.13
EAPI="3"
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit haskell-cabal
+inherit base haskell-cabal
MY_PN="Crypto"
MY_P="${MY_PN}-${PV}"
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}/${PN}-4.2.4-ghc-7.4.patch")
+
src_test() {
TESTS="SymmetricTest SHA1Test RSATest QuickTest HMACTest WordListTest"
diff --git a/dev-haskell/crypto/files/crypto-4.2.4-ghc-7.4.patch b/dev-haskell/crypto/files/crypto-4.2.4-ghc-7.4.patch
new file mode 100644
index 000000000000..a4ca6a702b68
--- /dev/null
+++ b/dev-haskell/crypto/files/crypto-4.2.4-ghc-7.4.patch
@@ -0,0 +1,27 @@
+--- Crypto-4.2.4-orig/Data/Digest/SHA2.hs 2011-09-08 10:30:07.000000000 +1000
++++ Crypto-4.2.4/Data/Digest/SHA2.hs 2011-12-20 13:28:26.401971284 +1100
+@@ -106,7 +106,7 @@
+ data Hash384 = Hash384 !Word64 !Word64 !Word64 !Word64 !Word64 !Word64 deriving (Eq, Ord)
+ data Hash224 = Hash224 !Word32 !Word32 !Word32 !Word32 !Word32 !Word32 !Word32 deriving (Eq, Ord)
+
+-instance (Integral a) => Show (Hash8 a) where
++instance (Integral a, Show a) => Show (Hash8 a) where
+ showsPrec _ (Hash8 a b c d e f g h) =
+ (showHex a) . (' ':) .
+ (showHex b) . (' ':) .
+@@ -146,7 +146,7 @@
+ where
+ bs = bitSize (head r)
+
+-instance (Integral h, Bits h) => Hash (Hash8 h) where
++instance (Integral h, Bits h, Show h) => Hash (Hash8 h) where
+ toOctets (Hash8 x0 x1 x2 x3 x4 x5 x6 x7) = bitsToOctets =<< [x0, x1, x2, x3, x4, x5, x6, x7]
+
+ instance Hash Hash384 where
+@@ -282,4 +282,4 @@
+
+ -- Test with:
+ -- ghc -no-recomp -O --make Data/Digest/SHA2.hs -main-is Data.Digest.SHA2.moduleTest -o moduleTest && ./moduleTest && rm moduleTest
+-moduleTest = runTestTT test_sha2
+\ No newline at end of file
++moduleTest = runTestTT test_sha2