summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-07-27 19:00:13 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-07-27 19:00:13 +0000
commit69c4b834a09cfcef73b1339da311cfe6ae79b2c0 (patch)
tree7ee98969e95d123768052b1e63ca42166ee294ac /dev-haskell
parentAdd USE=ipv6 support by Christian Affolter #277366. (diff)
downloadgentoo-2-69c4b834a09cfcef73b1339da311cfe6ae79b2c0.tar.gz
gentoo-2-69c4b834a09cfcef73b1339da311cfe6ae79b2c0.tar.bz2
gentoo-2-69c4b834a09cfcef73b1339da311cfe6ae79b2c0.zip
Version bump and fixes to dev-haskell/network. See bug #278545.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/network/ChangeLog13
-rw-r--r--dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch17
-rw-r--r--dev-haskell/network/files/network-2.2.0.0-ghc-6.10-build-fix.patch13
-rw-r--r--dev-haskell/network/network-2.2.1.4.ebuild29
-rw-r--r--dev-haskell/network/network-2.2.1.ebuild14
5 files changed, 82 insertions, 4 deletions
diff --git a/dev-haskell/network/ChangeLog b/dev-haskell/network/ChangeLog
index 528722a03cca..a7b7d0f15ce8 100644
--- a/dev-haskell/network/ChangeLog
+++ b/dev-haskell/network/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-haskell/network
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/ChangeLog,v 1.36 2009/04/19 10:21:08 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/ChangeLog,v 1.37 2009/07/27 19:00:13 kolmodin Exp $
+
+*network-2.2.1.4 (27 Jul 2009)
+
+ 27 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org>
+ +network-2.2.1.4.ebuild:
+ Version bump.
+
+ 27 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org>
+ +files/network-2.2.0.0-eat-configure-opts.patch, network-2.2.1.ebuild:
+ Make ./configure disregard unneeded flags --with-hc and --with-hc-pkg.
+ See bug #278545.
*network-2.2.1 (19 Apr 2009)
diff --git a/dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch b/dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch
new file mode 100644
index 000000000000..49c430da44a7
--- /dev/null
+++ b/dev-haskell/network/files/network-2.2.0.0-eat-configure-opts.patch
@@ -0,0 +1,17 @@
+Make sure ./configure can eat --with-hc and --with-hc-pkg without giving QA
+warnings.
+
+diff -rN -u old-network-2.2.0.0/configure.ac new-network-2.2.0.0/configure.ac
+--- old-network-2.2.0.0/configure.ac 2009-07-21 22:07:20.000000000 +0200
++++ new-network-2.2.0.0/configure.ac 2009-07-21 22:07:20.000000000 +0200
+@@ -14,6 +14,10 @@
+
+ AC_C_CONST
+
++dnl * dummy options to eat --with-hc= and --with-hc-pkg= flags
++AC_ARG_WITH([hc], [(dummy option)], [])
++AC_ARG_WITH([hc-pkg], [(dummy option)], [])
++
+ dnl ** check for specific header (.h) files that we are interested in
+ AC_CHECK_HEADERS([fcntl.h limits.h stdlib.h sys/types.h unistd.h winsock.h])
+ AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h netinet/tcp.h sys/socket.h sys/uio.h sys/un.h])
diff --git a/dev-haskell/network/files/network-2.2.0.0-ghc-6.10-build-fix.patch b/dev-haskell/network/files/network-2.2.0.0-ghc-6.10-build-fix.patch
new file mode 100644
index 000000000000..a0bb1d271415
--- /dev/null
+++ b/dev-haskell/network/files/network-2.2.0.0-ghc-6.10-build-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/network.cabal b/network.cabal
+index 8814063..237f45e 100644
+--- a/network.cabal
++++ b/network.cabal
+@@ -18,7 +18,7 @@ extra-source-files:
+ extra-tmp-files:
+ config.log config.status autom4te.cache
+ network.buildinfo include/HsNetworkConfig.h
+-build-depends: base, parsec
++build-depends: base<4, parsec
+ extensions: CPP
+ include-dirs: include
+ includes: HsNet.h
diff --git a/dev-haskell/network/network-2.2.1.4.ebuild b/dev-haskell/network/network-2.2.1.4.ebuild
new file mode 100644
index 000000000000..2b0ebec9c321
--- /dev/null
+++ b/dev-haskell/network/network-2.2.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/network-2.2.1.4.ebuild,v 1.1 2009/07/27 19:00:13 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal autotools
+
+DESCRIPTION="Networking-related facilities"
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/network"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/parsec"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=(" ${FILESDIR}/network-2.2.0.0-eat-configure-opts.patch ")
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ eautoreconf
+}
diff --git a/dev-haskell/network/network-2.2.1.ebuild b/dev-haskell/network/network-2.2.1.ebuild
index ebff4ce9ea2e..4f5226446e4a 100644
--- a/dev-haskell/network/network-2.2.1.ebuild
+++ b/dev-haskell/network/network-2.2.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/network-2.2.1.ebuild,v 1.1 2009/04/19 10:21:08 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/network-2.2.1.ebuild,v 1.2 2009/07/27 19:00:13 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal
+inherit base haskell-cabal autotools
DESCRIPTION="Networking-related facilities"
HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/network"
@@ -15,7 +15,15 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE=""
RDEPEND=">=dev-lang/ghc-6.6.1
- dev-haskell/parsec"
+ dev-haskell/parsec"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
+
+PATCHES=(" ${FILESDIR}/network-2.2.0.0-eat-configure-opts.patch ")
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ eautoreconf
+}