summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-02-28 04:59:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-02-28 04:59:33 +0000
commitbba9cd166839481189b1bde1d1628a2c1e56d671 (patch)
tree0a5d83cbb7497cd21e3a994b2d77d1d71d52bd2c /dev-haskell
parentVersion bump, resolves #354549 (diff)
downloadgentoo-2-bba9cd166839481189b1bde1d1628a2c1e56d671.tar.gz
gentoo-2-bba9cd166839481189b1bde1d1628a2c1e56d671.tar.bz2
gentoo-2-bba9cd166839481189b1bde1d1628a2c1e56d671.zip
removed old
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/happy/ChangeLog6
-rw-r--r--dev-haskell/happy/happy-1.15.ebuild60
-rw-r--r--dev-haskell/happy/happy-1.16.ebuild40
-rw-r--r--dev-haskell/happy/happy-1.17.ebuild43
4 files changed, 5 insertions, 144 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index bfe824dd163a..a4323482dd7d 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/happy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.48 2011/02/25 12:45:43 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.49 2011/02/28 04:59:33 slyfox Exp $
+
+ 28 Feb 2011; Sergei Trofimovich <slyfox@gentoo.org> -happy-1.15.ebuild,
+ -happy-1.16.ebuild, -happy-1.17.ebuild:
+ removed old
25 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> happy-1.18.2.ebuild:
ppc/ppc64 stable wrt #339161
diff --git a/dev-haskell/happy/happy-1.15.ebuild b/dev-haskell/happy/happy-1.15.ebuild
deleted file mode 100644
index 5bda71c1b165..000000000000
--- a/dev-haskell/happy/happy-1.15.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.15.ebuild,v 1.16 2007/10/31 12:57:48 dcoutts Exp $
-
-inherit base eutils ghc-package
-
-DESCRIPTION="A yacc-like parser generator for Haskell"
-HOMEPAGE="http://haskell.org/happy/"
-SRC_URI="http://haskell.cs.yale.edu/happy/dist/${PV}/${P}-src.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="doc"
-#java use flag disabled, bug #107019
-
-DEPEND=">=dev-lang/ghc-5.04
- doc? ( ~app-text/docbook-xml-dtd-4.2
- app-text/docbook-xsl-stylesheets )"
-# java? ( >=dev-java/fop-0.20.5 ) )"
-RDEPEND=""
-
-src_unpack() {
- base_src_unpack
-
- cd "${S}"
- epatch "${FILESDIR}/${P}-ghc66.patch"
-}
-
-src_compile() {
- econf || die "configure failed"
- if $(ghc-cabal); then
- echo "SRC_HC_OPTS += -ignore-package util" >> mk/build.mk
- fi
- emake -j1 || die "make failed"
- if use doc; then
- emake -j1 html || die "make html failed"
- #if use java; then
- # emake -j1 ps || die "make ps failed"
- #fi
- fi
-}
-
-src_install() {
- local docways
- if use doc; then
- docways="html"
- #use java && docways="${docways} ps"
- else
- docways=""
- fi
- # the libdir0 setting is needed for amd64, and does not
- # harm for other arches; einstall doesn't seem to work
- make install install-docs XMLDocWays="${docways}" \
- prefix="${D}/usr" \
- datadir="${D}/usr/share/${P}" \
- infodir="${D}/usr/share/info" \
- mandir="${D}/usr/share/man" \
- libdir0="${D}/usr/$(get_libdir)" \
- || die "installation failed"
-}
diff --git a/dev-haskell/happy/happy-1.16.ebuild b/dev-haskell/happy/happy-1.16.ebuild
deleted file mode 100644
index c388cc2a09ff..000000000000
--- a/dev-haskell/happy/happy-1.16.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.16.ebuild,v 1.12 2007/12/13 18:02:30 dcoutts Exp $
-
-CABAL_FEATURES="bin"
-inherit haskell-cabal autotools
-
-DESCRIPTION="A yacc-like parser generator for Haskell"
-HOMEPAGE="http://haskell.org/happy/"
-SRC_URI="http://haskell.org/happy/dist/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="doc"
-
-DEPEND=">=dev-lang/ghc-6.4
- || ( =dev-haskell/cabal-1.1.6.1 =dev-haskell/cabal-1.1.6.2 )
- doc? ( ~app-text/docbook-xml-dtd-4.2
- app-text/docbook-xsl-stylesheets )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}/doc" && eautoconf
-}
-
-src_compile() {
- cabal_src_compile
- if use doc; then
- cd doc
- econf || die "econf failed in /doc"
- emake -j1 || die "emake failed in /doc"
- fi
-}
-
-src_install() {
- cabal_src_install
- use doc && cd doc && dohtml -r happy/*
-}
diff --git a/dev-haskell/happy/happy-1.17.ebuild b/dev-haskell/happy/happy-1.17.ebuild
deleted file mode 100644
index 2eef64e46a61..000000000000
--- a/dev-haskell/happy/happy-1.17.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.17.ebuild,v 1.6 2010/07/01 19:56:36 jer Exp $
-
-CABAL_FEATURES="bin"
-CABAL_MIN_VERSION=1.2
-inherit haskell-cabal autotools
-
-DESCRIPTION="A yacc-like parser generator for Haskell"
-HOMEPAGE="http://haskell.org/happy/"
-SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 sparc x86"
-IUSE="doc"
-
-DEPEND=">=dev-lang/ghc-6.4
- dev-haskell/mtl
- doc? ( ~app-text/docbook-xml-dtd-4.2
- app-text/docbook-xsl-stylesheets )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- sed -e "s/BuildFlags(..)/BuildFlags(..), buildVerbose/" \
- -i "${S}/Setup.lhs"
- cd "${S}/doc" && eautoconf
-}
-
-src_compile() {
- cabal_src_compile
- if use doc; then
- cd doc
- econf || die "econf failed in /doc"
- emake -j1 || die "emake failed in /doc"
- fi
-}
-
-src_install() {
- cabal_src_install
- use doc && cd doc && dohtml -r happy/*
-}